File Copy Error (Invalid Characters or Length) Mac OS X Leopard to Windows Server 2003 SBS Share

I am having an issue with a Mac OS X user who is trying to put files on a Windows Server 2003 SBS server share.  The share has been setup as a Macintosh share and the user has permission 'Modify' permission on the directory/sub-directories.
The message the user is receiving is:  "You cannot copy some of these items to the destination because their names are too long or contain invalid characters for the destination.  Do you want to skip copying these items and continue copying the other items?"
I have also attached a screenshot of this message.
The file names that he is trying to copy does not have any symbols or special characters in the name, and the longest file name is only 23 characters (including extension).  He does not have problems with all of his files, but there are certainly enough to drive the user nuts (and me too for that matter).
Has anyone seen this message or have any idea why it may occur?  Thanks in advance!!
FinderScreenSnapz003.jpg
LVL 2
facelessmanchsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

strungCommented:
Is there any possibility that the Windows path name use characters or symbols that are not acceptable to the Mac (like a colon, for instance).
0
facelessmanchsAuthor Commented:
Nope...I looked at all the share path names.  None have spaces or special characters.
0
strungCommented:
If you google

"names are too long or contain invalid characters"  (with the quotes)

you will find a number of discussions of this, but some solutions seem quite esoteric and likely won't apply to your situation.
0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

facelessmanchsAuthor Commented:
Yeah...I Googled before posting here.
0
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
I am going to assume that you are copying files from a Mac to an SMB share?

If this is the case, no special characters such as " ¶ ¬ " ' are any others are allowed in the filename or directories.

You may want to look at a product called name cleaner to help you remove these special characters.
0
facelessmanchsAuthor Commented:
I am going to give the Name Cleaner program a shot.  I will advise on the result.
0
heteronymousCommented:
That or "A Better Finder Rename" which you have to buy in order to use for any large number of files.
0
nappy_dThere are a 1000 ways to skin the technology cat.Commented:
I have used namecleaner recently on a server with nearly 3TB of data.  Namecleaner performed with lightening speed in under 2 hours.
0
facelessmanchsAuthor Commented:
Unfortunately, I have still been unable to find a solution to this issue.  I have tried the Name Cleaner, but it still has issues.  If anyone else has any issues, I would appreciate the help.
0
mjbyersCommented:
I am experiencing the same issues using SBS and Leopard 10.5.2.  I can read and copy files from the server shares with no problem, however cannot copy from the Finder to the share.  I believe it may have something to do with the ".ds_store" files and file locking issues that are created on the server when the Finder attempts to copy the file.  I also read another post on another site that the issue may have something to do with "posix locking" on the SMB server.  Any help would be appreciated.
0
facelessmanchsAuthor Commented:
I just wanted to update this ticket and say that I have disabled SMB signing on the server.  I read that this may help, but it did not.
0
mjbyersCommented:
Ok...I have finally solved the issue but required the IT team to make the following changes to the SBS 2003 server (from a mac networking forum):

Open Default Domain Controller Security Settings.
Go to Security Settings, Local Policies, security Options.
Disable the following:
Domain member: Digitaly encrypt or sign secure Channel Data(Always)
Microsoft network server: Digitally sign communications (always)
Microsoft network server: Digitally sign communications (if client agrees)

Immediately after the changes were made I was able to read and write from all my network server shares using SMB.  Hope this helps.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
heteronymousCommented:
That issue should have presented a different error, perhaps you were seeing one. IE: unable to copy files period, not warnings about filenames (as OS X permits things that CIFS/SMB won't, and vice-versa).

That fix has been necessary for many with OS X clients. However, note that 10.5 does natively support smb digital signing
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Apple Networking

From novice to tech pro — start learning today.