SSIS Package problem access Web Service

we are calling a web service and getting the following error 'The input Web Services Description Language (WSDL) file is not valid' We work fine in our QA environment, but not in production.
mwryeAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Siva Prasanna KumarPrincipal Solutions ArchitectCommented:
I some how feel the URl pointing the WSDL file is wrong, check the WSDL by Trying to opening that WSDL URL in any web browser see if it is able to get the WSDL in the first place.
 
0
mwryeAuthor Commented:
Hi shivaspk.  I am on the DB side of things and while I have used the SSIS piece - I haven't really set up Web Services before and am not overly familiar with WSDL.

I can go to the WSDL and open in IE and see the internal workings and even get the webpiece in the code to work.  (Is taht what you were wanting me to do?)

I know that a URI is a Unique Resource Identifier but where in my package would I find that link?  

You should also know that some testing has shown that moving the WSDL to the C:\ in tests on other machines did indeed work so I think you are on the correct trail of it being the pointer.

Sorry for being slow about this.  There were others involved in creating this case who know more but they aren't currently available.



 
0
Siva Prasanna KumarPrincipal Solutions ArchitectCommented:
Oh sorry I am a java j2ee Developer with good web service background :) so have just the bare overview of SQL server.

see if this links are helpful.

http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2352721&SiteID=1

http://www.sql-server-performance.com/articles/dba/package_configuration_2005_p1.aspx

0
mwryeAuthor Commented:
Thanks for trying to help me on this.  No one seemed to be able to give me the answer.  We actually wound up calling MS and even they didn't answer it.  We did find the problem though.  It was the DTC settings on the new server.  We set those to No Authentication and it worked.
0
mwryeAuthor Commented:
For anyone who sees this solution and is having the same problem here is what we found out was wrong:

The issue related to the setup of the DTC (Distributed Transaction).  We had to call Microsoft directly to figure this out and even then it wsa touch and go.  I recommend that you start with the DTC configuration.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Languages and Standards

From novice to tech pro — start learning today.