• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 3173
  • Last Modified:

Cannot reinstall .net framework 2.0 service pack 1

I just installed QuickBooks Pro 2008 & it was running well. Today QuickBooks not start and after diagnosing the problems it appears to be related to a corrupt .net framework 2.0 service pack 1. I tried to uninstall it and got the error "the source cannot be found". I then used the Windows Cleanup utility to uninstall it. After a reboot I tried to reinstall it and got the error it is already installed (even though it does not show up in Add/Remove Programs.

How can I make sure all traces of .net framework 2.0 service pack 1 are removed from the registry or is there another utility I can us to make sure it is completely remove it. QuickBooks will not run without it. My system is Windows XP Professional SP2 with IE 7.0 & all current Windows updates.

Thanks, Roy
0
rbrother
Asked:
rbrother
1 Solution
 
briancassinCommented:
Go under this registry key
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\

and look through the entries until you find the microsoft.net framework once you find it remove the entire key.
0
 
MotoCrazyCommented:
See this Microsoft KB article on .NET installation problems:
http://support.microsoft.com/kb/908077

See the section on manually removing and reinstalling
0
 
orangutangCommented:
0
 
rbrotherAuthor Commented:
This was a perfect solution (Thank you). The .Net Framework cleanup tool removed all references to the .Net Frameworks and allowed me to reinstall them easily.
Roy
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now