• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1218
  • Last Modified:

Setting MSSQL 2005 timeout = 0 (neverending)

I have a database of about 10 million items, when I try and declare a primary key, it obviously times out. I'm using Microsoft Sql Manager to do this. Any idea how to run a sql query to set the timeout to 0??? Thanks, Chris.
  • 2
1 Solution
Jeff SCommented:
Have you looked at the WAITFOR in the Books Online help files?

WAITFOR(<statement>) [,TIMEOUT <timeout_value>]
Anthony PerkinsCommented:
Run the SQL Script from the Query Window.
jumpstart0321Author Commented:
I am running it from the query window.
Jeff SCommented:
From the application, the API (ADO.NET) will have settings for timeout. From SSMS, there are settings in the Tools]Options area. Please be more specific.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now