What can cause computer to self test, post and then go to blank screen, blinking cursor? Please help~~

Hi,
  I've had good luck with my IBM NetVista X41 17" all in one.  It was working flawlessly until just this week when it won't boot into windows.  It will post with no error messages, I can get into BIOS and change all the settings.  It reads my internal devices properly (IDE drive, DVDRW)  At startup I can hit f12 which takes me to boot selector and I can boot to CD with a bootable CD.  I've removed the hard drive and put it in another computer and I can read the drive fine.  I've tried using XP Pro recovery console to fix the boot sector and have done a inplace repair of the XP system files and still no luck. It completes post, goes to boot to the hard drive and you hear a quick chug of the hard drive, the screen changes and I'm left with a blinking cursor.  I've removed and replaced the RAM, I've removed the BIOS battery and tried booting after replacing it.  All the fans seem to be working.  I even took another drive that had XP loaded on a primary partition (like my current drive is set up) and tried booting to that and after post message, I get black screen and blinking cursor.  I suspect there is a step in the boot process where the motherboard tells the hard drive to start loading system files and it seems to be getting stuck here.  
  Any way to test the motherboard?  I assume the CPU is good if I can boot from CD and run the recovery programs from the CD?  The ram tests out OK on the Post self test.  I assume the power supply is good.  Any other ideas?  I haven't erased my hard drive and done a fresh install but I figured if a inplace install of the system folder didn't fix it that erasing and starting over wouldn't be any different?  Any other ideas or experience with this computer?  I watched for a while on ebay to find this computer as it is a few years older now and I noticed several other X41s in the 15" and 17" model that were listed as booting to blank screen and cursor so apparently others have had this problem as well.  

  Thanks for taking time to read this far and offer any advice you can give!!
docknibbsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

2PiFLCommented:
This is usually a driver problem, does it boot in safe mode?
0
debuggerauCommented:
Are you using the IBM rebuild CD's or a standard XP version?

I suspect the registry is corrupt, and a rebuild is required, but if you like to test it, clone the disk somewhere first...
0
docknibbsAuthor Commented:
Hello,
  There is no option or no ability for me to boot into safe mode.  That option becomes active as you are booting into windows and I can't get that far.  At the POST I get the option to hit f1 for setup and f12 for boot order.  I've changed no drivers and the hard drive works fine in another computer for read/write functions.  I haven't tried booting to the hard drive in another computer.
  I installed XP Pro on this using a standard 'oem' XP Pro cd and had no problems authenticating with Microsoft using the sticker on the case.  I've done this process on two units (one 15" model, one 17" model) and had no problems with stability or booting in the past 6 months or so that I've had them.

After poking around on google I found this thread that talks about problems in the boot sector.  If this applies to me, how could this get messed up, and why wouldn't in an place install of XP Pro fix this?

see link:
http://www.redflagdeals.com/forums/showthread.php?s=7100e9d1a1373951ab94d0370dda9541&t=152261&page=2
0
Hey MSSPs! What's your total cost of ownership?

WEBINAR: Managed security service providers often deploy & manage products from a variety of solution vendors. But is this really the best approach when it comes to saving time AND money? Join us on Aug. 15th to learn how you can improve your total cost of ownership today!

bminkerCommented:
Boot the computer using your XP install disk. Select the option to repair using recovery console. Log in if prompted. If no password was set then it will be administrator and a blank password. Run chkdsk and reboot. If still no go then go back to recovery console and run fixboot and fixmbr.
0
JohnnyCanuckCommented:
Many IBMs of that vintage have problems with the capacitors on the motherboard.  Here are some of the symptoms.

Motherboard fails to POST.
Memory Test Fails.
System randomly and/or constantly reboots itself.
Fails to fully boot (or even install) Operating System.
System randomly and frequently freezes.
Random & frequent 'Blue Screens of Death'
BSoD or hard freeze under heavy drive activity (Either RAID, SCSI, or standard ATA)
CPU temps abnormally higher than usual under typical or less load.
*CPU VCORE & other system voltages are erratic or far out of tolerances.
Resetting the system after a freeze and the system will not repost.
(You have to completely power down then power back up.)

See this link
http://www.badcaps.net/pages.php?vid=5
0
nobusCommented:
you can also test the ram and disk
memtest86+   from www.memtest.org
disk :  
http://www.tacktech.com/display.cfm?ttid=287      
0
Strabuck45Commented:
You could try booting from a linux live cd such as knoppx too eliminate the hard drive as the issue.



You could also try removing the hard drive and placing it in a different computer to see if you can still read and write to it.
0
docknibbsAuthor Commented:
OK,  A special thanks to all for your input and suggestions.
I can boot from CD to a WinXP install CD so I assume that this means the CPU, Memory, and Motherboard seem to be working OK.  AM I wrong?
I could boot to Knoppix live CD but doesn't that only prove that the computer can boot from CD and doesn't answer why it won't boot from the hard drive?
I've attached the hard drive to another computer through an external usb cable and it reads and writes fine.
I've not tried putting the hard drive in another computer through an ide cable and trying to boot that way as this doesn't always work depending on boot setup on different computers correct?
I've read about IBM having 4 boot sectors instead of one and needing a restore CD to work properly but I've had no problem using my WinXP Pro CD to format and install windows on other IBM Netvista all-in-ones before.
Is there a way to know if the motherboard is the problem?  After the bios self test messages what is the next step when the screen goes blank and the hard drive gives a little chug..is it looking for the boot.ini file information?
I've been hesitant to run the fixmbr command as it will destroy my partition tables and wipe out my drive.  I have everything backed up but if I really wanted to wipe the drive wouldn't it be better to just boot to the XP CD, delete the existing partiton and do a brand new complete install?
Thanks
docknibbs
0
bminkerCommented:
fixmbr will not wipe out your drive. It merely re-writes the master boot record. It can make an OS not boot if not installed in the default location (first partition) but since it does not boot anyway, you will be no worse off.
0
mastooCommented:
Try a different IDE cable, and less likely to help but switch the hard drive to first in the boot order.  Otherwise I'm liking what you said - fresh install, new partitions, and no quick format (let the format scan the drive for errors).  At that point you'll be looking at either bad hard drive or the mobo IDE controller (usually can be replaced with add-in card).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
docknibbsAuthor Commented:
There is only one position on this IDE cable since it is a special cable designed for a special motherboard that fits behind the LCD screen.  (this is an all in one design)  I assumed since the cable reads the drive in the BIOS that the cable is OK.  You are correct that we could try a PCI IDE add on card but I'll try the wipe clean option first.  I also need to check if the BIOS allows booting to a USB external.  Anyone have any luck putting XP on say a 2GB USB flash drive and trying to boot from that?  Just a thought..
0
debuggerauCommented:
BartPE can...
0
nobusCommented:
why not run ram and disk tests as suggested? they are non-destructive
0
docknibbsAuthor Commented:
It turned out that you were right, a complete format, partition with one partition, and reinstall solved the problem  I still don't know why it happened, maybe a bad sector on a hard drive but time will tell.  thanks for your effort!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Components

From novice to tech pro — start learning today.