Crystal Enterprise DYNAMIC PARAMETER List of Values error

I created a Crystal XI report, which runs fine (in the designer, and after being deployed to Crystal Enterprise.)

When I added a dynamic parameter, it runs fine in the designer, but throws an error after being deployed to Crystal Enterprise.

List of Values failure: fail to get values. [Cause of error: putParamValuesForMissingInfo ReportSDKException(-2147482892):Failed to open the connection. Details: [Database Vendor Code: 4060 ] Logon failed. Details: [Database Vendor Code: 4060 ] Failed to open the connection. Failed to open the connection. C:\WINDOWS\TEMP\{BD709572-B0A7-4411-B8E4-C6129148A025}.rpt Details: [Database Vendor Code: 4060 ]]

Unable to retrieve Object.
List of Values failure: fail to get values. [Cause of error: putParamValuesForMissingInfo ReportSDKException(-2147482892):Failed to open the connection. Details: [Database Vendor Code: 4060 ] Logon failed. Details: [Database Vendor Code: 4060 ] Failed to open the connection. Failed to open the connection. C:\WINDOWS\TEMP\{BD709572-B0A7-4411-B8E4-C6129148A025}.rpt Details: [Database Vendor Code: 4060 ]]

Has anyone seen this, or does anyone know how I can work around it?
AptDevAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wykabryanCommented:
This could be a few things.
You may need to restart the service the controls the LOV server within the environment.  
You may need to verify the report is correctly pulling the LOV into the report and process it correctly.
You may need to schedule the LOV to populate it with data rather than populating on-demand.  (Right click on the LOV and select schedule, then enter in your dates and time.)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mlmccCommented:
Is this Enterprise 10?

Since dynamic parameters were added in CR XI Enterprise 10 may not support them.

mlmcc
0
wykabryanCommented:
I believe by his/her indication it is BO XI...
0
mlmccCommented:
That may be but BO XI is not Crystal Enterprise.

mlmcc
0
AptDevAuthor Commented:
Excellent Response... it pointed me in exactly the right direction.  Thank you!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Crystal Reports

From novice to tech pro — start learning today.