mail stuck in queue

hi im running sbs2003 w exchange.  this is a server im not familar with.  just a random client.
main problem is mail is just sitting in the queue.  i have cleaned the queue and checked relaying, etc.  all looks ok.  whenever i send an email it does not leave the queue.  whether its via DNS or isp.com.
have telnet port 25 and seems ok.
have checked blacklists and cant see them on anything.  unless theres a usualy one i should be looking at.  

please help!
LVL 6
rick81Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rick81Author Commented:
i noticed in the bottom of the queue i get an error saying the remote server did not respond to a connection attempt.
0
rick81Author Commented:
i also get the error 421 when trying to send out via a pop account internally via the isps mail server
0
dexterhomeCommented:
without checking up on the error ID's, is the issue simply an authentication problem on outbound mail. This can be set in the properties of the default connector. Try running all tests with firewall turned off as well. Hope this is helpful.
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

peakpeakCommented:
Is this happening to one recipient only? In that case read here:
http://kbase.pscs.co.uk/index.php?article=279
0
ZanemwestCommented:
error 421 indicates that the remote smtp service is not available, so with this in mind i would guess that the smtp domain you are trying to send to is having an issue.

try from the exchange server to telnet to the remote server on port 25.
0
rick81Author Commented:
a reboot of the server - as a last resort fixed the issue.
seems error 421 may have been exceeded connections to the isp mail server.  
mail is flowing fine now.

no points awarded but thankyou for your responses
0
rick81Author Commented:
ive got this issue happening again. now i get smtp protocol error occured.
once i rebooted the server it worked.  for about 1/2 day.  i had to restart it this morning and now no good
any ideas?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.