• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 442
  • Last Modified:

mail stuck in queue

hi im running sbs2003 w exchange.  this is a server im not familar with.  just a random client.
main problem is mail is just sitting in the queue.  i have cleaned the queue and checked relaying, etc.  all looks ok.  whenever i send an email it does not leave the queue.  whether its via DNS or isp.com.
have telnet port 25 and seems ok.
have checked blacklists and cant see them on anything.  unless theres a usualy one i should be looking at.  

please help!
0
rick81
Asked:
rick81
1 Solution
 
rick81Author Commented:
i noticed in the bottom of the queue i get an error saying the remote server did not respond to a connection attempt.
0
 
rick81Author Commented:
i also get the error 421 when trying to send out via a pop account internally via the isps mail server
0
 
dexterhomeCommented:
without checking up on the error ID's, is the issue simply an authentication problem on outbound mail. This can be set in the properties of the default connector. Try running all tests with firewall turned off as well. Hope this is helpful.
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
peakpeakCommented:
Is this happening to one recipient only? In that case read here:
http://kbase.pscs.co.uk/index.php?article=279
0
 
ZanemwestCommented:
error 421 indicates that the remote smtp service is not available, so with this in mind i would guess that the smtp domain you are trying to send to is having an issue.

try from the exchange server to telnet to the remote server on port 25.
0
 
rick81Author Commented:
a reboot of the server - as a last resort fixed the issue.
seems error 421 may have been exceeded connections to the isp mail server.  
mail is flowing fine now.

no points awarded but thankyou for your responses
0
 
rick81Author Commented:
ive got this issue happening again. now i get smtp protocol error occured.
once i rebooted the server it worked.  for about 1/2 day.  i had to restart it this morning and now no good
any ideas?
0

Featured Post

Free tool for managing users' photos in Office 365

Easily upload multiple users’ photos to Office 365. Manage them with an intuitive GUI and use handy built-in cropping and resizing options. Link photos with users based on Azure AD attributes. Free tool!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now