Error applying Transforms, Palm Zire 22

Having trouble with my Palm Zire 22(Z22).  The software that comes with the Palm to manage it worked fine until a few days ago.  The computer was part of a workgroup, a server was added, the computer added to a domain and since then the software will not work.  When we launch the program the following error comes up: Error applying transforms.  I am not able to see the version of the software and the user doesn't know as well.  Also, the network person who was hired to set this up quit before completeing the job, so I'm left to pick up the pieces.  As fare as the user/president of the company knows, the tech added to the computer to the domain and that is it.  Common sense says there is more to the story and only the tech knows the answer.

I found several people had this issue and they used Micorsoft's unintstall utility to remove the program.  Next they would re-install and would be back in business.  I have tried this utility but it will not uninstall the Palm software even after a complete shut down and restart.  Has anyone seen this before?  If so, what had to be done to fix it?  I will try to boot to the last known good cinfiguration and keep my fingers crossed, I'm looking for other ideas in case this doesn't work.

I also will not be able to get my hands on this computer again until late this afternoon.  Any suggestions that are given I will not be able to respond until then if they were successful or not.

Thanks for the help.
lbstechAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

and235100Commented:
What error(s) do you get when attempting to uninstall?
Did you follow the removal instructions here:
http://kb.palm.com/SRVS/CGI-BIN/WEBCGI.EXE/,/?St=53,E=0000000000851529349,K=2311,Sxi=8,Case=Obj(1844) ?
0
lbstechAuthor Commented:
No I haven't tried this one, out of all the search I did I never came across this article.  I will give it a try.

Just a FYI here is the Micorosoft utility I tried but didn't work: http://support.microsoft.com/kb/290301
0
souseranCommented:
@ and235100,

When I click on the link you provided, I get the following message:

Session Expired

Your Knowledge Server session has expired and may no longer be accessed.

Solution ID:

If you were searching for a specific Solution ID, the number provided was incorrect. Please go back and try again.

@ lbstech,

If you go into Add/Remove Programs, is there an entry for the Palm Software? Can you boot into Safe Mode and try the uninstall from there?

DISCLAIMER: Deleting the following may (with a HIGH probability) result in the loss of user HotSync data.

In C:\Program Files and delete any of the following    

* C:\Program Files\Palm
* C:\Program Files\palmOne
* C:\Program Files\Handspring

After that, try the Windows tool you found again.

Then try to reinstall the software from the CD that came with the Z22.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

and235100Commented:
Their website isn't very good, unfortunately.
Browse to the Knowledge Library from the link on this page: http://euro.palm.com/europe/en/support/z22.html
Solution ID 1844
0
lbstechAuthor Commented:
I worked on this issue several hours last night and no luck.  Add/Remove programs does not work, even is safe mode to remove the palm software.  I even had a chat going with Palm support, they walked my through removing all registry settings and folders from C:\program files related to the palm.  I had to reboot so that ended the chat.  Tried to run the install and error applying transforms comes up about a minute in to the install, hit OK and it exits the install.  At that point it was late so I called it a day, I will work on it more this afternoon.  What a pain in the butt this has turned out to be.

What are your thoughts on something is messed up with the registry?  Yet all other programs are working fine, so I'm not convinced this could be it.  Just putting it on the table to see what other think.

Soreran:  If try going to http://support.micorsoft.com then in the search type in 290301 and hit search.  The first article that comes up in the list should be Description of the Windows Installer CleanUp Utility.  This is the article the link should have taken you too.

and235100: I tried solution 1844 last night, no luck.
0
souseranCommented:
@ lbstech,

When a message begins with an @ and a participant's name, that part of the message is directed specifically to that participant. The information in my earlier message about the problematic link was directed to and235100, who remedied the situation by providing alternate instructions for the Palm information. I had no problems finding your Microsoft link.

It appears the problem is a missing file with the extension .MST. Since you've spent time with Palm technical support, it's likely the file isn't one normally associated with the Palm desktop. It may be that having the unit on a domain has changed the default email client, and the Palm is now looking for conduits it didn't need before.

When the computer was added to the domain, what else happened at that time? Was any new software installed on the unit? Do you have an Exchange server in your environment? Prior to being added to the domain, which email program were you using? Versamail? Outlook? Outlook Express?

0
lbstechAuthor Commented:
Sorry about that souseran, I'll remember that for next time.  Thanks for explanation.

When the computer was added to the domain I was told the tech worked on that computer for 45 minutes.  Naturally I asked what other programs did he loaded; as we all know adding the computer the domain is no 45 minute project.  The user was very confident that was all he did to the computer; my opinion is opposite of that.  Bottom line, no one knows what else was done.

As for the domain server, all it handles is authentication and provides storage space; no other server is on the network.

Outlook Express is the email program the user has been using and that has not changed.  Email is handled by an outside provider and is working fine.
0
souseranCommented:
Could you do a search on the PC for all files that have a Modified date that matches the date the PC was added to the domain? That would probably shed some light on what else might have been done to the PC.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
lbstechAuthor Commented:
I will give that a try and let you know what I dig up.  It will not be until later this afternoon.  Thanks.
0
lbstechAuthor Commented:
I broke down, called Palm tech support and paid $25 for a level 2 tech.  There is a lot more done to the registry when the Palm software is installed then I originally thought.  The tech had me go in to several places in the registry to delete items, I started to take notes but there were so many place I went I stopped just to get it done in a timely manor.

I recommend if Palm article 1844 does not fix this issue call Palm support, the problem is pretty deep in your registry.

Thanks to everyone for your ideas.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Smartphones

From novice to tech pro — start learning today.