Shared printer loses ability to print. User must go to services.msc and restart printer spool

Workstation was just upgraded to Lenovo M52. Using the same printer HP Laserjet 1020 USB. Installs just fine, prints test page and then moments later nothing prints with no error messages. Printer spools all the jobs in the queue. Controlling workstation cannot print. Once printer spool is restarted in services.msc , all printer job print just fine. Then moments later , the printer stops again.
Any help would be greatly appreciated !
cj
cjslingAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
JohnnyCanuckConnect With a Mentor Commented:
On the computer with the printer attached, restart it in safe mode, navigate to "C:\Windows\System32\Spool\Printers", and delete all files (make sure you have "show hidden files and folders" enabled in the "view" menu).  Restart the computer.  Did this help?
0
 
Darr247Commented:
I was under the impression the 1020 was not intended to (i.e. couldn't) be shared.
You're saying that sharing it used to work just fine?

I can tell you empirically a 1022N works out cheaper than a 1022 plus a JetDirect 175x if you end up going that route.
0
 
cjslingAuthor Commented:
Thanks for the responses. I will be able to try some of the suggestions next Tue. I will be visiting the site at that time. I will let you know.
Just to clarify some things:
Yes. This printer worked fine prior to the workstation upgrade. When it was first installed , it was printing just fine , then suddenly stops. You can see the jobs sitting in the quue.
I go to services and stop and start the print spool and everything prints just fine and continues to be ok, then suddenly it stops again.
As a really bad workaround , I wrapped the services.msc file with admin rights so the end user can stop and start the spooler.

Thanks again for the suggestions and responses.
cj
0
SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

 
f-kingCommented:
Hi
Have you uninstalled the printer and reinstalled it again.
, the upgrade could have confused it.
0
 
cjslingAuthor Commented:
Yes I have reinstalled serveral times. Thanks
0
 
cjslingAuthor Commented:
Thank you so much. And sorry for the delay. I thought I had closed this one out. Your solution worked like a charm!
cj
0
All Courses

From novice to tech pro — start learning today.