Problem with new iis site with permissions

Greetings.  I have a new installation of win2k8 I am attempting to setup.  It is running IIS 7.

The machine is not a member of a domain.

I created a new site (and application pool).  The path I am using is not the inetpub folder but rather c:\IISWebsites\NewWebsite.

I am having 2 problems, first when navigating to the address www2.mysite.com (which is configured within the site as the name).  First, the site is giving me the following error:

403 - Forbidden: Access is denied.
You do not have permission to view this directory or page using the credentials that you supplied.

Second, the when using the "test connection" accessed by right clicking on the site and selecting basic settings authentication appears to be ok, i get the following message:
The application pool identity is valid.

But the authorization gives me a warning:
The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that <domain>\<computer_name>$ has Read access to the physical path. Then test these settings again.

Any thoughts would be appreciated.

Cheers,
rugby148
rugby148Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

meverestCommented:
check the permissions on 'c:\IISWebsites\NewWebsite' - compare it to the wwwroot default web site folder/s.

Cheers.
0
RalphHxyzCommented:
In conjunction with meverest above the iusr_machinename , ASPNET and IIS_WPG users need Read permission at the minimum IUSR_machinename for HTML pages.
0
rugby148Author Commented:
All of the permissions matched perfectly.  I ended up resolving the issue by re-installing windows server.  Recreated the sites and all was well.  Thanks for the help.
0
RalphHxyzCommented:
The most dependable methods to fixing Microsoft problems:
        1. Reboot
        2. Re-install
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rugby148Author Commented:
yeah.  unfortunately that is a true statement.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
OS Security

From novice to tech pro — start learning today.