HTTP 401.1 - Unauthorized: Logon Failed

IIS Experts,

I need to run IIS 5 on a Windows XP Pro workstation.  I've installed IIS (I went the route of downloading the Windows XP with SP2 executable from Microsoft's site and using the /integrate flag since the workstation is in a remote location).  

When I attempt to view a simple HTML file in wwwroot by visiting http://localhost, I receive the errors "You are not authorized to view this page" and "HTTP 401.1 - Unauthorized:  Logon Failed".  

This workstation's computer account was sitting in an OU that restricted the installation of IIS via a Group Policy Object setting.  I've moved the computer account into an OU without any GPOs attached and ran "gpupdate /force" to refresh the list of policies that apply to the machine.  I then installed IIS using a local admin account.  

When I viewed the NTFS permissions on the wwwroot folder after I saw the error message originally, I saw several "Deny" entries for accounts, including a deny write entry for the IUSR account.  I removed the deny entries and propaged the permissions down but still receive the HTTP 401.1 error message.

Any suggestions?
LVL 11
snoopfroggAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

meverestCommented:
Hi,

1) try resetting the password on the IUSR account, then enter that same password under the IIS security->anonymous config,
2) try changing the anonymous user under IIS manager for that web site to some known user (e.f. admin account)

Cheers,
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
snoopfroggAuthor Commented:
I tried option 1 and it worked!  

When I went back and checked the "Allow IIS to control password" checkbox, though, I received the "You are not authorized to view this page.  HTTP 401.1" errors again.  What are the security implications of my leaving this as a static password?  Since this machine isn't publicly exposed, I think this is a risk that's acceptable.
0
meverestCommented:
There is no great security concern for leaving it static.  The synchronise function is one of convenience rather than any kind of black magic or security feature.

Cheers!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft IIS Web Server

From novice to tech pro — start learning today.