Can't delete PDF files from File Server?

We have a file server running Windows Server 2003 Standard.  On frequent occasions we have PDF files that cannot be renamed, deleted or moved on a shared network drive.

I've tried using various unlocking tools to scan the files but none report the file to have any locks on them and none can delete these files.  The only way you can delete, move or rename the files is to reboot the server (not a practical solution!).  Also if you check the open files/sessions on mmc these files don't appear to be on the list!

Any Ideas?
Scotty_EdAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JohnjcesCommented:
One question comes to mind, as this has happened here and caused us a minor "problem".

When a file on one of our servers was deleted, renamed or whatever via a client, the file would simply still "appear" to be on the server. Refreshes of the client would still not make the rename or delete appear or disappear as the case may be.

However, when we actually checked on the server directly, from its console, the file was in fact deleted, moved or renamed.

Have you checked this kind of activity? I.E. client only issues.

Just a thought.

John
0
captainCommented:
Hi

We had a similar issue with files created from Mac clients. The solution was to check the permissions on the File services for Macintosh and make sure that these are correct for the designated users.

I think you will have to isolate the pattern of users, look at the common element and try reproducing the problem. Then fix the permissions.

Sorry if this sounds general for now but if you come back with some more info we may be able to pinpoitn the culprit.

hth
capt.
0
Scotty_EdAuthor Commented:
Ok, the files are definetly still there as you can still them to view them.  The visability is the same whether you are on the server or the conencting clients.

Permissions is not an issue as even logged in as the Network Administrator of the Domain, I still can't delete the file.

The error message I'm recieving is:  cannot delete xxxx.pdf It is being used by another person or program.  Close any programs that might be using this file and try again.

After checking the open files list from the MMC there is no mention of the file in question.  Also there is only 1 or 2 users that would have access to the files and neither of them are using them.  I can also reset the security permissions for the file and take ownership, but even after doing these things it doesn't make a difference?

As I say I've tried various unlocking tools and none of them report that the file is open or that there are any locks on them.  This only happens with PDF files.  As I say if I reboot the sever the problem will go away, but this server needs to be 99.999% of the time!

This problem is doing my nut in!
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

captainCommented:
Scotty

I take the answer is no, but these are definitely not Macintosh users? And you definitely don't have Macintosh file permissions enabled.

These are the SAME symptoms we had with the above.

hth
capt.
0
Scotty_EdAuthor Commented:
Hi Capt,

It's not Mac users - they are all Win XP SP2.  I run vista and have the same issue.  As I say you can't even delete the files from the server console (Win 2003 Server Std).

cheers
Scott
0
captainCommented:
Hi Scott

ok, sorry if this is a little rudimentary...

On the server Administrative tools =>File Server Management, do these appear as open files?
Also make sure there are no Terminal services connections open.

Which Virus checker are you using, exclude PDFs from the scannable items and reboot.

Just some ideas.
capt.
0
doublehornCommented:
Having the exact same problem on our Win2003 Std file server. In my case, the files that can't be manipulated are PDFs that have all been created by Acrobat Professional 7.0.7 on a WinXP network workstation and stored on a share. Previously, I could restart the server and simply delete using explorer.exe, but that stopped working after the last server restart. Things I've tried so far that didn't work:

-taking ownership of file with domain admin account & deleting using explorer.exe - no luck
-deleting using cmd shell del /F - also fruitless
-removing read-only and hidden properties, indexing and encryption properties - all off by default
-checking session manager for open sessions involving the problem files - there never are
-tried sysinternals handle.exe, which shows no open handles to problem files
-sysinternals filemon, regmon, procmon using dozens of probable and some improbable filter criteria, then no filter criteria, but this list is really too big to be useful, even exported out to a database.
-sysinternals process explorer - turned up nothing with any part of the filename, although this is a handy utility otherwise
-for kicks, powered down client workstation that created the problem files originally - same
-submitted problem to Adobe, but we all know this will be worthless
-temper tantrum - also no good, but made me feel a bit better.

So I'm out of ideas and my user will be adding roughly 100MB a week in PDFs that no one can delete, rename or move. Any Windows process gurus left out there?
0
Scotty_EdAuthor Commented:
doublehorn - Found someone else that has a similar problem to our dilema.  One common item is that we both use McAfee 8.0 Patch 13 for our client side Antivirus.

What AV do you use?
0
doublehornCommented:
McAfee VirusScan Enterprise 8.5i scan engine 5200.2160, DATs are usually up to date. Interesting that a McAfee product is common to all of these circumstances. As luck would have it, I restarted the problem file server this morning and now I CAN delete all the PDF files that were previously stuck, even with previous server restarts. Fair to say this problem is intermittent (my favorite kind).

To test this McAfee theory, I'm going to momentarily turn off the On Access Scanner function on the server next time my user is going to save her PDF to the share. I'll post the result to this thread
0
Scotty_EdAuthor Commented:
I have just used my complimentary Microsoft support incident and have reported the issue to them.  I have been given possible solution.  Editing the registry to enable oplocks - no idea if this change has been effective yet as I had to reboot the server meaning all locks were released anyway.

Will update in a months time to see if any PDF files lock up after this change.  If all is well I will upload the steps involved.
0
itadminjltCommented:
Has turning on Oplocks done anything for you??
0
Scotty_EdAuthor Commented:
Ok, so far so good - not had any issues with locking PDF's since the change that Microsoft reccommended that I make.

Here is the steps I was issued:

Backup the registry.

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MRXSmb\Parameters\
OplocksDisabled REG_DWORD 0 or 1
Default: 0 (not disabled) Note The OplocksDisabled entry configures Windows clients to request or not to request opportunistic locks on a remote file.

You can also deny the granting of opportunistic locks by setting the following registry entry to 0:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
EnableOplocks REG_DWORD 0 or 1
Default: 1 (enabled)

Cheers
Scott
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
DuelundCommented:
Hi Scotty

We have similar problem....
Did you make the registry setting on the server or on all the workstatoon ?

Best regards,
Duelund
0
WORKS2011Austin Tech CompanyCommented:
@Scotty_Ed I'm assuming you did this on the server since you wrote about restarting the server, however to be 100% do you mind clarifying? Thanks. Also, does it matter what server platform, any difference between 2003, 2008, SBS, etc?
0
Scotty_EdAuthor Commented:
Hi, yes is was the server that this was done on. Had no problems for the past few years since implementing the fix with no undesired side effects. Still using the same server to date although it is now a VMWARE virtual machine.

I did mine on windows server 2003 standard. I can't comment on any other versions, up to you if you wish to try it on another version.
0
WORKS2011Austin Tech CompanyCommented:
Thanks for the update.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Software

From novice to tech pro — start learning today.