Cisco 2620 Basic Pass Through router Configuration - what am I doing wrong?

Have never played with Cisco routers before.
My itention is to configure this router to be a simple pass-through router.
Takes in T1 data connection and give it out to our firewall.
More details on my issues is also posted here:
http://www.experts-exchange.com/Hardware/Networking_Hardware/Routers/Q_23112828.html

When I connect the router with below configuration directly to one od my PCs using the crossover cable, I am not able to browse internet. The static IP address of the PC is setup to be in valid range of IP addresses to work fine with Cisco router.
The PC has this settings
IP: 66.192.xxx.82
Mask: 255.255.255.240
GW: 66.192.xxx.81    (router's Ethernet Port IP address)

Below is my current Cisco router configuration:
To repeat - my idea is for router to act simply as a dumb pass-through box:

TM2600#show config
Using 696 out of 29688 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service password-encryption
hostname TM2600
!
enable secret 5 $1$W9f/$DyurKPoGeMHIkZqG.vDEL1
enable password xxxxx
!
!
!
!
!
ip subnet-zero
!
!
!
!
interface FastEthernet0/0
 ip address 66.192.xxx.81 255.255.255.240
 no ip directed-broadcast
 no ip mroute-cache
 speed auto
 full-duplex
 no cdp enable
!
interface Serial0/0
ip address 66.162.yy.218 255.255.255.252
 no ip directed-broadcast
 no ip mroute-cache
 no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 66.162.yy.217
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password xxxxxxxxx
 login
!
no scheduler allocate
end


Issue that I have is that I can't browse through this router.

When router boots up this is what is displayed:
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-I-M), Version 12.0(7)T,  RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Tue 07-Dec-99 02:12 by phanguye
Image text-base: 0x80008088, data-base: 0x807AAF70

cisco 2620 (MPC860) processor (revision 0x600) with 26624K/6144K bytes of memory
.
Processor board ID JAD06010CC8 (2165562803)
M860 processor: part number 0, mask 49
Bridging software.
X.25 software, Version 3.0.0.
1 FastEthernet/IEEE 802.3 interface(s)
1 Serial network interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)



Press RETURN to get started!

Passed
00:00:09: %LINK-3-UPDOWN: Interface FastEthernet0/0, changed state to up
00:00:09: %LINK-3-UPDOWN: Interface Serial0/0, changed state to down
00:00:10: %SYS-5-CONFIG_I: Configured from memory by console
00:00:10: %SYS-5-RESTART: System restarted --
Cisco Internetwork Operating System Software
IOS (tm) C2600 Software (C2600-I-M), Version 12.0(7)T,  RELEASE SOFTWARE (fc2)
Copyright (c) 1986-1999 by cisco Systems, Inc.
Compiled Tue 07-Dec-99 02:12 by phanguye
00:00:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, chang
ed state to up
00:00:10: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed sta
te to down
00:00:24: %LINK-3-UPDOWN: Interface Serial0/0, changed state to up
00:00:25: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed sta
te to up
00:00:55: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, changed sta
te to down
TM2600>

Pay attention to the last LINEPROTO line changing state to DOWN.

Why is the T1 WIC card port going down after booting up is completed?

Thank you in advance
TerraceAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

cstosgaleCommented:
Hi,

this is not working because you have not configured any ISDN signalling or encapsulation info on your T1. How you do this will depend on the type of T1 signalling provided by your ISP. Is it a T1 CAS or an ISDN PRI?

Here are some guides for configuring a T1, but how you do this will depend entirely on the type of service provided by your ISP.

If you want to confirm that the serial interface is down, type  "show int s0/0"

Also bear in mind that with your current configuration, the PC you have configured will be completely exposed to the internet as you have no access-lists.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
TerraceAuthor Commented:
Cstosgale,
thank you for your time and help.

Here is some info I got from Time Warner - my T1 provider
CSU/DSU @ Router Information:
Framing: ESF
Line Code: B8ZS
Encapsulation: PPP


As far as output when I ran command Show int S0/0 here it is:
TM2600#show int s0/0
Serial0/0 is up, line protocol is down
  Hardware is PQUICC with Fractional T1 CSU/DSU
  Internet address is 66.162.21.218/30
  MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive set (10 sec)
  Last input 00:00:01, output 00:00:03, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0 (size/max/drops); Total output drops: 0
  Queueing strategy: weighted fair
  Output queue: 0/1000/64/0 (size/max total/threshold/drops)
     Conversations  0/1/256 (active/max active/max total)
     Reserved Conversations 0/0 (allocated/max allocated)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     4976 packets input, 89568 bytes, 0 no buffer
     Received 4976 broadcasts, 0 runts, 0 giants, 0 throttles
     204 input errors, 0 CRC, 202 frame, 0 overrun, 0 ignored, 2 abort
     1491 packets output, 38066 bytes, 0 underruns
     0 output errors, 0 collisions, 491 interface resets
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

Line protocol is down?

What should I do?

Thanks
0
TerraceAuthor Commented:
I turned on encapsulation ppp on my Serial Port and I can browse on my PC now.

I'll play with plugging it into firewall. Probably will get into some issues :)
0
cstosgaleCommented:
By the way, you might want to get EE to mask out the IP from the previous show interface in your previous post! :)

You will also need to know the ISDN switch type, which will be one of these:-

North America  
  primary-4ess
 AT&T 4ESS switch type for the U.S.
 
  primary-5ess
 AT&T 5ESS switch type for the U.S.
 
  primary-dms100
 NT DMS-100 switch type for the U.S.
 
  primary-ni
 AT&T National ISDN switch type


Next You will need to configure the T1 connection as follows:-

isdn switch-type [switch-type from list above]
controller t1 0
  framing esf
  linecode b8zs
  pri-group

interface s0/0
  no ip address

interface s0/0:23
 ip address 66.162.yy.218
 encapsulation ppp
(I'm not sure if you'll need the next bit)
 dialer-group 1
dialer-list dialer-group list 101
access-list 101 permit ip any any


This is the article I built this config from: http://www.cisco.com/en/US/docs/ios/12_0/dial/configuration/guide/dcchant.html#wp4834
0
bfasonCommented:
The encapsulation was the problem. This isn't an ISDN line so there will not be a need for a dialer. All configuration will be done on int s0/0. I believe stuknhawaii took care of any configuration questions you had. If not you should respond on your original post.

Glad you have it working now.
B
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.