limited or no connectivity

XP Pro sp2. working fine yesterday. user unable to login. limited or no connectivity. appl log shows following com+ event system detected an inconsistency in internal state. assertion "getlasterror=122L"
failed at line 201 of d:/xp_slp/com/com1x/src/events/shared/sectools.cpp
brossierAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

artoaperjanCommented:
Hello
is it stand alon or network ?
using DHCP or static IP ?

mor info pls.
0
briancassinCommented:
Have you tried logging in with a different user account ? You may have a corrupted user account.

Are there any other errors in the app log or in the system log ?
0
brossierAuthor Commented:
tried to login as different user, same results. plugged laptop into same port. no problems.
i quoted error in appl log in original question. "getlasterror=122L.... no such at MS support
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

brossierAuthor Commented:
is on network, using dhcp
0
briancassinCommented:
what do you mean by this "plugged laptop into same port. no problems"
so is working fine and this is only happening when you plug the laptop into different ethernet ports or something? I don't quite understand the comment
0
artoaperjanCommented:
could you pleas put the IPconfig/all
so we can see
0
brossierAuthor Commented:
re laptop in port. As a test of the wiring, I plugged my laptop into the port the system in question is attached to. Laptop boots and logs into network fine. Problem is in workstation.

IPconfig /all shows correct host name, correct domain, hybrid as node type... also show autoconfig enabled, autoconfig ip address enabled, autoconfig ip address is 169.254.43.10... no gateway

unable to ping anything
0
briancassinCommented:
your not getting a DHCP address your getting an APIPA... which means it isn't reaching the DHCP server which might be causing the other error..

several things
did you use the same cable to test with ? if not use the same cable see if you can still connect fine...


1. Is your windows time and date correct on the workstation ?

2. Go to the command prompt and do ipconfig /release then ipconfig/renew what happens ? do you still get 169.xxx if so continue...

3. If you go to your network connections then the properties of the connection then tcp/ip properties do you have any numbers in the ip address sections even if you have it selected for DHCP. do you have an alternate configuration listed ?

4. Try assigning a static IP address can you now ping the default gateway and other pc's on the network ? if not then you may your probably looking at an issue with the network card.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
brossierAuthor Commented:
To all who responded, Thanks. I've located the problem and it is ME!!!... DHCP service in the server had stopped and as users shut down and rebooted the next day they got no IP address from the server. I should have known..... too many brushfires and too old for this crap anymore.
Thanks again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Protocols

From novice to tech pro — start learning today.