provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server

I am running SQL Server 2005 Enterprise Edition, on a Dell  PowerEdge 2950 64 bit server.When I try to connect to the data in the database i recieve this error message:

An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)

The Windows Firewall service isnt enable, I have allowed local and remote connections using both TCP/IP and Named Pipes and the SQL Server Browser is enabled. Any ideas why I still can't make the connection?
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Faiga DiegelSr Database EngineerCommented:
Ive used some of the tips here:



And double check all configurations you have, sometimes we missed it :p
Open SQL Server 2005 Surface Area COnfiguration
Select the Surface Area Configuration for Services and Connections
Under Database Engine , you will find remote Connections.
Select Local and Remote Connections and Using both TCP/IP and named Pipes.
mdotenAuthor Commented:
Faiga16: I have looked at both of those forms and the problem still exists.

Indianguru2: I stated that I had already done that in the quesiton description.
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Did you restart the SQL service after doing it?
mdotenAuthor Commented:
mdotenAuthor Commented:
Missed a setting in the web.config file.

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Visual Basic Classic

From novice to tech pro — start learning today.