How to undo a suspended windows update

I recently tried to do Windows updates and the sytem locked up on me. I had to manually restart it, everything came back up fine.
I am now trying to install the XOsoft engine on this server, and the remote installer is giving me the following error.
"An installation for Microsoft.NET Framework 2.0 Service Pack 1 is currently suspended. You must undo the changes made by that installation to continue."
How can I undo this suspended install?
LVL 1
Methodman85Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

YiogiCommented:
Retrying to install the framework SP1 should detect that installation didn't finish and repair it.
0
Methodman85Author Commented:
I've tried, the update installer stops responding. I've done this twice, maybe I should remove .NET 1.1 and 2.0, and try them all again from the start...
The problem is that this is occuring on our Exchange Server, which as you know complicates things greatly.
0
YiogiCommented:
Don't try from windows update simply download the redistributable for DotNet Framework 2.0 SP1 and try from there.
http://www.microsoft.com/downloads/details.aspx?familyid=0c1b0a88-59e2-4eba-a70e-4cd851c5fcc4&displaylang=en
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

Methodman85Author Commented:
Ah thank you, I will try this.
I have to scedule a restart though. Will have to be later this afternoon.
0
Methodman85Author Commented:
Well it looks like IIS was the cause, while it was running I could not perform any .NET updates. It kept trying to stop it, and some other service would keep restarting  it (Don't know which one). This conflict caused the update to hang time after time.
I had to stop the Service, and uninstall 2.0 to get rid of the suspended update.
0
YiogiCommented:
kk glad you solved this out. It probably kept restarting because you have the service to autorestart on failures. Try double clicking on it in your services console (services.msc) and check that out. You might want to disable the restart feature or leave it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.