• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1106
  • Last Modified:

IIS6 Log Files Not Rolling

Hi - We're having an issue with IIS6 web logs. I'm not precisely sure how it started happening but it's in the last month or so. For some reason, IIS6 log files are not properly rolling. They just get bigger and bigger each day. If I go in and change from daily to hourly or turn local time on or off, it will create a new log file at that point and then just keep filling that one up.

Any ideas? :)
  • 5
2 Solutions
Sam PanwarSr. Server AdministratorCommented:

which log format you have selected and the path which you provide for log file have the Iuser permission or not.

Have you enabled localtime for rollover the file in the log properties.
kcmurphy1Author Commented:
W3c Extended Log File Format, the path had access for administrators and system, nothing else... we've been able to write to it before for over a year now, but we were using it by "when file size reaches 50MB" which wasn't the best setting for managing our reporting. I added iusr for the moment, I'll see if it rolls at the next hour mark.

I've tried it with localtime for rollover enabled and disabled both, neither seems to work.
kcmurphy1Author Commented:
Giving iusr access did not fix the issue. The files are writing there, they're just not closing off one file and opening a new one properly.
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

kcmurphy1Author Commented:
I just looked in the metabase... I'm wondering if LogFileTruncateSize might not be the problem.. we changed to do it periodically but the truncatesize remains in the metabase. Here's the metabase entry for one of the sites in question:

<IIsWebServer	Location ="/LM/W3SVC/619796104"
		LogExtFileFlags="LogExtFileDate | LogExtFileHost | LogExtFileTime | LogExtFileClientIp | LogExtFileUserName | LogExtFileSiteName | LogExtFileComputerName | LogExtFileServerIp | LogExtFileMethod | LogExtFileUriStem | LogExtFileUriQuery | LogExtFileHttpStatus | LogExtFileWin32Status | LogExtFileBytesSent | LogExtFileBytesRecv | LogExtFileTimeTaken | LogExtFileServerPort | LogExtFileUserAgent | LogExtFileCookie | LogExtFileReferer | LogExtFileProtocolVersion | LogExtFileHttpSubStatus"

Open in new window

kcmurphy1Author Commented:
Hmm.. the overall setting for IIS was set to 50 meg rollover still. I changed that to hourly as well, we'll see if that fixes it at 1. :)
kcmurphy1Author Commented:
Looks like the following tasks combined improved the situation:

1) Set logging settings for "web sites" to hourly + local time
2) give IWAM user higher permission level (what specifically it apparently needs I'm not sure, still tweaking that)
3) Restart IIS

This clearly worked on one of the two boxes in the cluster; the second one I left out the "Restart IIS" step, so confirmation of that is pending the next hour mark.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now