Login Prompt by windows for asp.net site

Hi,
I have a asp.net website,when we deployed it to production server,everytime any of the user is trying to access the website there is a Username/Password Prompted by windows(which it should not be doing)...i dont understand why is it doin..and all of sudden it started prompting it...can any one of you guide me as to why all of a sudden it started prompting for this login and password.
aspnetdevAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DinethCommented:
Hi
You can enable Anonymous in IIS (In the IIS Manager ,go the web stie properties,->Directory Secutiry->Edit -> Enable Anonymous Authentication.
If you want to read more about ASP.net authentication, you can read the following article.
http://aspnet.4guysfromrolla.com/articles/031204-1.aspx

Thanks
Dineth
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mdouganCommented:
You have to check the permissions settings for the virtual directory of the website using the IIS manager.  It is possible that the virtual directory is set to require windows authentication.  You should turn that off and grant authority to everyone to execute scripts.
0
aspnetdevAuthor Commented:
i have following in my web.config file
<authentication mode="Windows" />
and
<authorization>
    <deny users="?" />
</authorization>
but my virtual directory has anonymous access and Windows authentication checked....will web.config over write virtual direcotry setting or will Virtual Dir setting overwrite the web.config file.For any of the answer msdn url stating that will really help me.
Thanks
0
mdouganCommented:
You should leave the web.config file as it is.  However, in the Virtual Dir setting, remove the Windows Authentication checkmark.  I know that if you remove that in IIS, that it won't matter what you have in the web.config file... though, I haven't tried denying any users in the web.config... maybe if you do, then you might have to have windows authentication enabled.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
ASP.NET

From novice to tech pro — start learning today.