Debian Cyrus no imap connection

hello,

yesterday i've had my Cyrus 2.2 IMAP server running on my fresh Debian lenny box.
now i cant even telnet to localhost port 143 anymore.
It reads:

telnet localhost imap
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
Connection closed by foreign host.

I've checked the hosts.allow there is an entry ALL: ALL
the /etc/services has the imap port in it.

The /etc/imapd.conf is:
   configdirectory: /var/imap
   partition-default: /var/spool/imap
   admins: root cyrus
   sasl_pwcheck_method: saslauthd

The /etc/cyrus.conf has:
imap            cmd="imapd -U 30" listen="imap" prefork=0 maxchild=100
in it.

i've checked the var/mail.log:

set maximum file descriptors to 256/256
Feb  6 14:09:35 server cyrus/ctl_cyrusdb[2839]: archiving log file: /var/imap/db/log.0000000001
Feb  6 14:09:35 server cyrus/ctl_cyrusdb[2839]: archiving database file: /var/imap/mailboxes.db
Feb  6 14:09:35 server cyrus/ctl_cyrusdb[2839]: archiving log file: /var/imap/db/log.0000000001
Feb  6 14:09:35 server cyrus/ctl_cyrusdb[2839]: archiving log file: /var/imap/db/log.0000000001
Feb  6 14:09:35 server cyrus/ctl_cyrusdb[2839]: done checkpointing cyrus databases

I'm really stuck at this one :(
yesterday everything worked fine, now it doesn't anyore.
pentheseAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

http:// thevpn.guruCommented:
Are you sure it is running at that port ?

netstat -an | grep 143

if nothing is echoed then it is not running .
0
pentheseAuthor Commented:
Thanks for your response.

server:~# netstat -an | grep 143
tcp        0      0 0.0.0.0:143             0.0.0.0:*               LISTEN
tcp6       0      0 :::143                  :::*                    LISTEN
0
pentheseAuthor Commented:
Little update, i've changed the listening port to 144 and everything is working.
Checked if courier or exim is active but they aren't running.
How can i find out which imap daemon is active on 143?
0
pentheseAuthor Commented:
We're going to install SBS 2003 server to get around the very cryptyc cyrus server.
Thanks for the help.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.