.NET Framework 2.0 won't uninstall

I installed Quickbooks 2008, but it doesn't open, it just hangs.  I traced it down to a problem with .NET 2.0  When I try to uninstall it, however, it tells me the installation source isn't available.  I have tried manually removing .NET but I still get that error afterwards.  I need to get Quickbooks installed for our CFO and she comes back from vacation in 2 days.  Help!
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

The installation source isn't available for .net 2.0 or for quickbooks?
oops, i just figured it out.. .net.

what's the actual problem with it?

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bridgetimillerAuthor Commented:
Actually, I just found a .NET cleanup utility by Aaron Studner or Stubner.  That fixed it all up.  Thank you though!  I'll give you the points :)
awww thanks, but i dunno that they were deserved. but thanks anyway :D
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Editors IDEs

From novice to tech pro — start learning today.