RDP redirects printer without local configuration

The problem is that a redirected printer through RDP does not seem to transfer the local configuration. On most HP printers for example, it's possible to enable a 3rd or 4th tray in the drivers, but this is all forgotten when it's redirected. It seems all standard settings are used, which of course results in the wrong tray being used.

I've tried to add some fake printers to check how the configuration is transferred to the terminal server, but the 3 HP drivers I've tried does the same thing (LaserJet 2300, LaserJet 4050, LaserJet 5N), uses all standard settings on the terminal.

The terminal server is in no way connected to the network where the printer is located, so it's not possible to reach the printer through anything but RDP.

I need to somehow be able to have a printer on the terminal server that prints to a tray that is not normally enabled in the drivers on the clients printer.

Any suggestions?
Blaze-Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Blaze-Author Commented:
I've tested this on both Windows Server 2000 and 2003 by the way, but I really only need a solution for the 2003, in case there's a difference.
0
James MontgomeryCommented:
Hello Blaze-,

Printing and terminal services are two ingredients not always keen to mix.

I'm not sure if there is a native way to resolve this easilly... but I know of a 3rd party product which i have seen succeed.

http://www.tricerat.com/screwdrivers.php

Regards,

JimboEfx
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Blaze-Author Commented:
Thanks for the comment JimboEfx, I'll have a look at it asap.
0
Blaze-Author Commented:
Thanks for the answer. I believe your answer is pretty much the only solution to the problem, which is unfortunate when the terminal server I have  the problem with is not ours, and those who have it most likely wont allow a 3rd party software. Still, I've tested ScrewDrivers and it looks like it could do the job.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.