• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 658
  • Last Modified:

Server has slow NIC outgoing speed, but fast incoming

I have a server that when I copy a file to it, it is very fast. But if I copy from it, it slows down to about 1Mb/s. This happens when copying from and to machines even on the same switch.

The NIC is set to 100Mb/s and full duplex. The switchport is set the same way and is set for portfast.

I havent tried to use the 2nd NIC in the server but I'm curious if I'm missing something here. It is a new server.

The switch is a cisco 2950. There are no errors on the switchport either.
0
fina27
Asked:
fina27
1 Solution
 
tfarraritpsCommented:
If the duplex etc is all the same then i would try the following:

1) Try a different port on the switch.
2) Swap out the CAT5 cable for another one and try it with that.
3) Install latest NIC drivers.

I have had this exact issue before, but it was down to a duplex issue...
0
 
markmeulemansCommented:
Try setting up the switch port and NIC to auto-negotiate duplex and speed.  I generally try to avoid manually configuring these unless it won't work without it, because of issues like this.
0
 
fina27Author Commented:
Well I could do that but it kind of defeats the purpose of what I'm trying to fix. I actually fixed the problem. I did a show interface on a switchport and it was showing thousands of "deferred packets." Which I looked up and it was a bug in the IOS version I had with manually setting duplex. I upgraded the IOS and everything was fine. Thanks for the help anyway!
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now