No network connectivity with RHEL 5 Server

I am asking this question again since I never got any solution. Additionally, I have more relevant information to this problem. I've a RHEL5 on a SunFire Server connecting through a LinkSys SRW2024 (24-port) switch. The switch is brand-new out of the box so it's settings should be set to default, unless a gremlin got in there at the factory while it was being shrink-wrapped in plastic. I am using the same subnet for the server as the switch. All the link lights are on and a double-checked by issuing the "ethtool eth0" command, says that the link was detected. I am not running DNS, DHCP, or anything else on this Linux server; I am entering in static IPs for the time being. I used 192.168.1.1 as the static IP address with a netmask of 255.255.255.0 and the gateway address left blank. I use either the GUI-driven network manager to enable the NIC card, or an eth0 up and an eth0 down. I am able to ping the localhost (127.0.0.1) as well as 192.168.1.1. However, I  am unable to ping the switch, or any of the network client workstation. I get the classic "destination host unreachable" error.  Someone suggested I try a crossover cable even though most of these switches have auto-uplink built in.  The crossover cable didn't make a difference.  I also confirmed that auto-link is running and that  I could simply use a patch cable. I tried connecting workstation clients directly to the server, (using 192.168.1.2 as the client address) instead of through the switch. The server nor the workstation could see one another.  I've tried setting a default gateway and that doesn't make a difference. I have also disabled SE Linux and the firewall. So iptables and filtering should not be an issue. I've tried telnetting (also manually specifying port 25) and I get:

"telnet: connect to address <address>: No route to host
telnet: Unable to connect to remote host: No route to host"

Upon seeing this, I figured "Maybe the switch is screwed up" even though it is brand new out of the box. I was able to see both client workstations THROUGH the switch. Not only that, I was able to use the LinkSys configuration webview from either client. So the only machine that cannot see anything else is the server. I checked the routing tables via netstat and route and I get the following (abridged output):

"192.168.1.0   *   255.255.255.0
 169.254.0.0   *   255.255.0.0"

I again checked eth0 and the loopback device with "ifconfig eth0" and "ifconfig lo". It shows things as I would expect. I decided to try traceroute. Traceroute can't see a thing from the server. It can't get to the switch or to the client whether I have the client plugged in directly or not. Next, I decided to try nmap from both the clients AND the server. If I issue "nmap 192.168.1.0/24" from the client, it sees everything on the network. However, it says that all 1680 ports on the server (192.168.1.1) are being filtered. If I issue that same command from the server, it says that is is filtering only 1671 ports, with 9 open ports running. What the heck?! I have the firewall and iptables turned off. I don't understand. I've restarted xinetd with no change in behavior. I must admit that I am not a network expert but I have played around enough with a typical Linux workstation/server to administer some of the basics. Have I configured something wrong?  What am I missing? Please help ASAP! I'm pulling my hair out!
jazzkiAsked:
Who is Participating?
 
ravenplConnect With a Mentor Commented:
Please provide output from following commands

ip link
ip addr
ip route
iptables -L INPUT -nx
iptables -L OUTPUT -nx

consult /proc/net/dev, and confirm there are no errors on the link reported by kernel.
0
 
rokovConnect With a Mentor Commented:
>If I issue "nmap 192.168.1.0/24" from the client, it sees everything on the network. However, it says that all 1680 ports on the server (192.168.1.1) are being filtered.

Looks like you have no connectivity problems but sume sort of filtering enabled in the server.
Can you post some more information:
1. iptables -L
2. chkconfig --list
0
 
jazzkiAuthor Commented:
Ravenpl:
Here was the output you requested:

"ip link" yields:

"ip addr" yields:
   1: lo:<LOOPBACK, UP, LOWER_UP> mtu 16436 qdisc noqueue
      link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
      inet 127.0.0.1/8 scope host lo
      inet6:: 1/128 scope host
            valid_lft forever preferred_lft forever

   2: peth0:<NO-CARRIER,BROADCAST,NO ARP,UP> mtu 1500 qdisc pfifo_fast qlen 1000
       link/ether fe:ff:ff:ff:ff:ff brd ff:ff:ff:ff:ff:ff

   3. eth1:<BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
       link/ether 00:15:17:3e:ef:24 brd ff:ff:ff:ff:ff:ff
   
   4. eth2:<BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
       link/ether 00:15:17:3e:ef:27 brd ff:ff:ff:ff:ff:ff

   5. eth3:<BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
       link/ether 00:15:17:3e:ef:26 brd ff:ff:ff:ff:ff:ff

   6. eth4:<BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000
       link/ether 00:14:4f:a8:43:84 brd ff:ff:ff:ff:ff:ff
       valid_lft forever preferred_lft forever

   7. eth5:<BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
       link/ether 00:14:4f:a8:43:85 brd ff:ff:ff:ff:ff:ff

   8. eth6:<BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
       link/ether 00:14:4f:a8:43:86 brd ff:ff:ff:ff:ff:ff

   9. eth7:<BROADCAST,MULTICAST> mtu 1500 qdisc pfifo_fast qlen 1000
       link/ether 00:14:4f:a8:43:87 brd ff:ff:ff:ff:ff:ff

 10. sit0: <NOARP> mtu 1480 qdisc noop
       link/sit 0.0.0.0 brd 0.0.0.0

 11. vif0.0:<BROADCAST,NO ARP,UP,LOWER_UP> mtu 1500 qdisc noqueue
       link/ether fe:ff:ff:ff:ff:ff brd ff:ff:ff:ff:ff:ff

 12. eth0:<BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue
       link/ether 00:15:17:3e:ef:25 brd ff:ff:ff:ff:ff:ff
      inet 192.168.1.1/24 brd 192.168.1.255 scope global eth0
      inet6 fe80::215::17ff::fe3e::ef25/64 scope link
      valid_lft forever preferred_lft forever

"ip route" yields:
    192.168.1.0/24   dev   eth0   proto   kernel   scope   link   src   192.168.1.1
    169.254.0.0/16   dev   eth0   scope  link

"iptables -L INPUT -nx" and "iptables -L OUTPUT -nx" yield the same thing:
   Chain INPUT (policy ACCEP)
   target   prot  opt  source       destination

I did not see any errors in /proc/net/dev

Rokov: Was there a particular service you were looking for under the chkconfig --list command? It's hard to give you the full output, as I have to write it out by hand. :-/
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
ravenplConnect With a Mentor Commented:
I can see two interfaces up, eth0 and eth4. Maybe You set up the eth0, but it's the eth4 is connected to switch?

Next, I don't know why eth0 got "qdisc noqueue", do You?
0
 
ravenplConnect With a Mentor Commented:
try changing to pfifo with: tc qdisc add dev eth0 root pfifo
0
 
jazzkiAuthor Commented:
Ravenpl: Thanks for the recommendation. I'll try it out this morning and get back to you.
0
 
jazzkiAuthor Commented:
Ravenpl: I made sure to turn off ALL interfaces except eth0. I honestly don't know why eth0 returned with "qdisc noqueue". I tried your suggestion with the "tc" command. There is still no change in the behavior.  I tried activating ALL of the 8 cards with different static IPs. It didn't make a difference what I plugged into, I can't ping. Additionally, I've noticed some more odd behavior and am wondering whether it is the interface cards themselves, at least the one that came stock on the motherboard. After tinkering around with bringing the interfaces up via the GUI or with "ifconfig ethX up/down", the link lights would not come on. Once I rebooted, everything was fine.
0
 
ravenplConnect With a Mentor Commented:
Can You get some liveCD distro, and run on the server? Fetch ip from DHCP?
Cause frankly, I'm rather out of ideas currently. The liveCD should tell us whether it's OS configuration or hardware problem.
0
 
jazzkiAuthor Commented:
ravenpl: I used the KNOPPIX distro. Same problem unbelievably. All 4 interfaces don't work. I can't believe this. Additionally, it doesn't even recognize the extra 4-port PCI-X network card. Although i suspect that is because it might be newer hardware and I am using an older version of KNOPPIX.
0
 
gheistConnect With a Mentor Commented:
How it "does not work"? Do you configure using gui or command line?
Can you ping interface's own IP address? Can you ping default router?
0
All Courses

From novice to tech pro — start learning today.