Pix newb, question on ports and external IP

Hello

I've been brought on board a place that previously had IT managed by a consulting company. The company has been pretty much holding us hostage for all of its passwords, configurations, etc. I've been able to work out everything I needed to except the Cisco PIX unit. Last week, I was forced to use the password reset procedure to break into it to reconfigure it for our new T1. Cisco equipment is a new area for me, and one I've enjoyed the challenge of figuring out under pressure. I think I'm mostly squared away, except for 2 questions:

1.) I'm configured to use 3 IPs - one for the Pix system (VPN users login with it), another for NAT, and the last for our MX (mail.internetdomain.com). Previously, before the T1 switchover, we could internally go to mail.internetdomain.com and it would map correctly to our internal mail server. Now it won't. The DNS maps to the correct, new external MX IP, but traffic won't reach the mail server. However, if I am on an external connection, I successfully reach the mail server. This is not a huge problem, since we aren't down and mail traffic externally flows fine, but it was convenient for people internally to go to their OWA using the mail.internetdomain.com address instead of the internal IP. I'd also like to understand it principlly to further my knowedge.

2.) VPN ports. If I understand it correctly, the VPN is configured to use access list 101. I went to go enable additional ports needed for some new network services, but it got me thinking - based on my configuration, how is standard windows file sharing even working? I'd like to enable some other ports, but I figure I'd fully understand how it works first.

PIX Version 6.3(5)
interface ethernet0 10baset
interface ethernet1 10full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 10.0.0.7 pri_mx
access-list 101 permit ip 10.0.0.0 255.255.255.0 172.16.1.0 255.255.255.0
access-list 101 permit ip host pri_mx host 12.36.120.5
access-list acl_out permit icmp any any
access-list acl_out permit tcp any host 72.18.225.81 eq imap4
access-list acl_out permit tcp any host 72.18.225.81 eq https
access-list acl_out permit tcp any host 72.18.225.81 eq smtp
access-list 105 permit ip host pri_mx host 12.36.120.5
access-list 105 permit ip host pri_mx 192.168.2.0 255.255.255.0
access-list inside_access_in permit ip any any
pager lines 18
logging on
logging timestamp
logging standby
logging buffered warnings
logging history warnings
logging queue 1024
mtu outside 1500
mtu inside 1500
ip address outside x.x.x.1 x.x.x.x
ip address inside 10.0.0.2 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool clients 172.16.1.1-172.16.1.254
pdm location 10.0.0.0 255.255.255.0 inside
pdm location pri_mx 255.255.255.255 inside
pdm location 172.16.1.0 255.255.255.0 inside
pdm location 12.36.120.5 255.255.255.255 outside
pdm location 192.168.2.0 255.255.255.0 outside
pdm history enable
arp timeout 14400
global (outside) 1 x.x.x.2 netmask x.x.x.x
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) x.x.x.3 pri_mx netmask 255.255.255.255 0 0
access-group acl_out in interface outside
access-group inside_access_in in interface inside
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 10.0.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
tftp-server outside 172.16.1.11 \
floodguard enable
sysopt connection permit-ipsec
sysopt noproxyarp inside
crypto ipsec transform-set mcset esp-3des esp-md5-hmac
crypto dynamic-map mcmap 1 set transform-set mcset
crypto map dyn-map 20 ipsec-isakmp dynamic mcmap
crypto map dyn-map client configuration address initiate
crypto map dyn-map client configuration address respond
crypto map mc-map 20 ipsec-isakmp
crypto map mc-map 20 match address 105
crypto map mc-map 20 set peer 12.36.120.3
crypto map mc-map 20 set transform-set mcset
crypto map mc-map 30 ipsec-isakmp dynamic mcmap
crypto map mc-map client configuration address initiate
crypto map mc-map client configuration address respond
crypto map mc-map interface outside
isakmp enable outside
isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp key ******** address 12.36.120.3 netmask 255.255.255.255 no-xauth no-conf
ig-mode
isakmp identity address
isakmp keepalive 60 5
isakmp client configuration address-pool local clients outside
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 1
isakmp policy 10 lifetime 50400
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup group1 address-pool clients
vpngroup group1 dns-server 10.0.0.10
vpngroup group1 default-domain adcomfg.pri
vpngroup group1 split-tunnel 101
vpngroup group1 idle-time 1800
vpngroup group1 password ********
telnet 172.16.1.0 255.255.255.0 outside
telnet 10.0.0.0 255.255.255.0 inside
telnet 172.16.1.0 255.255.255.0 inside
telnet timeout 10
ssh timeout 5
management-access inside
console timeout 0
terminal width 80
Cryptochecksum:4152810d0461ffe15429d38abe36b113
adcomfgIT ManagerAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Robert Sutton JrSenior Network ManagerCommented:
DNS pointers........ Make sure they are correct on your LAN since you can access it remotely....
0
adcomfgIT ManagerAuthor Commented:
For number one, I was able to solve it with an Alias command on the pix. I am not sure why it worked before, the old configuration didn't have an alias in the list. Odd.

I'm still at a loss for the ports on the VPN though.
0
travisllCommented:
The line below is allowing all the traffic from 10.0.0.0 255.255.255.0 to 172.16.1.0 255.255.255.0
the permit IP tells it to allow all tcp and udp ports.
So you should not need to allow any unless the traffic is not on one of those two networks.
 
access-list 101 permit ip 10.0.0.0 255.255.255.0 172.16.1.0 255.255.255.0

If you need more info just post a reply.

Travis Llewellyn
Network Administrator
Communication Federal Credit Union
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
ZuzzyCommented:
For the mail access, you cannot boomerang through a PIX firewall.  This means if you have a NAT hide of a server (eg mail server) that represents the server's inside IP as a publicly addressable IP on the external interface (ie what you would generally use NAT for) you cannot connect to the public address from the inside.  Draw it and it makes sense.  You must use split DNS, so internally the DNS returns the internal address; externally, the DNS returns the external address.

--Chris
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware Firewalls

From novice to tech pro — start learning today.