Overriding client keyboard layouts

Is there anyway, in 2003, to override a clients keyboard layout and have them fixed to the UK?

We have tonnes of thin clients, of various makes, and we seem to have issues with users connecting to our TS boxes and reporting that they have US keyboard layouts. Now, I suspect the problem is 50% duff-stuff, and 50% that some of our chaps just arent reading the setup list correctly.

However, I'm sick of having to deal with the managers moaning at me. So, I'm after a way that I can say "Ignore whatever keyboard layout the thin client reports to have and JUST USE THE UK !".

Is that possible in any way, shape, or form ?

Olly
LVL 1
stonnewayAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Madison PerkinsConsultantCommented:
download SetLocale and give it a shot.
http://www.spectrodisplay.nl/frames.html
0
stonnewayAuthor Commented:
Hmmm, tried that in the logon script this morning using

setlocale 00000809 00000809

for keyboard and location, but it doesnt help. Even running it by hand on each user session doesnt appear to change a thing.

Any other suggestions ?
0
Madison PerkinsConsultantCommented:
I have been away from to office with the flu for the past few days.  i will be back on monday. i will give this a shot when i get there.  i use wyse thin clients of 3 different types.  1200le and two other models.  i will report back on monday.
0
stonnewayAuthor Commented:
Any joy ?
0
DenegarCommented:
Please try one of the following methods to stop your Windows 2000/2003 terminal/citrix server from detecting thin clients' keyboard layouts:


1. Edit the registry manually on your servers so that the "HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layout\IgnoreRemoteKeyboardLayout" DWORD value has data equal to "1". (You may have to create this value.)


2. Add the following to a computer Startup script via Active Directory Group Policy or a similar scripting method (make sure it is all in one line):

REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layout" /v IgnoreRemoteKeyboardLayout /t REG_DWORD /d 1 /f


3. Put the following in a *.reg file and run it on each server.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout]
"IgnoreRemoteKeyboardLayout"=dword:00000001


I hope this helps!

Jeremy Denegar
Manager of Information Technology
Township of Esquimalt
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.