Microsoft Access database file clipboard behavior

When selecting records in Access database and copying and pasting into Excel spreadsheet, copied records paste as bitmap image of an envelope.  How can the clipboard behavior be changed to paste the copied records as text into the Excel spreadsheet?
jhendersinAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
Jeffrey CoachmanConnect With a Mentor MIS LiasonCommented:
jhendersin,

Does this only happen going from Access to Excel?
Or does it happen from Access to Word as well?.

Do you have any Excel addins installed that might be intercepting the paste command?

What happen if you try to "activate" (double-click, Right-Click), this envelope bitmap?

Very strange indeed!
:-O

JeffCoachman
0
 
Scott McDaniel (Microsoft Access MVP - EE MVE )Infotrakker SoftwareCommented:
Is one of your columns an OLE Object column?

You can copy/paste basic Text and Numeric data between Access and Excel, but you can't copy OLE objects successfully ...
0
 
BadotzCommented:
Have you tried the "Paste Special" option?
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
jhendersinAuthor Commented:
Yes, unfortunately, paste special also pastes the bitmap, not the Access data.
0
 
jefftwilleyCommented:
Can you outline the steps you take to copy and paste? This is strange behavior and it almost sounds like you're linking to the data vs pasting it in.
0
 
Jeffrey CoachmanMIS LiasonCommented:
jhendersin,

When you paste to Excel are you somehow holding down the Shift Key?

In Excel, holding down Shift when you click the Edit menu, reveals a "Paste Picture", hidden menu option.
This will paste the Access data as a picture. (This is the behavior you describe)

Could you somehow be activating the Shift key while pasting to Excel?

In Excel, try just using Ctrl-V (the standard Paste shortcut key)

Hope this helps

JeffCoachman
0
 
jhendersinAuthor Commented:
The steps for this issue are:

(1)  Highlight all records in a MS Access Database table;
(2)  Right-click and select Copy - or - click on the Edit menu and select Copy;
(3)  Open new blank workbook in Excel;
(4)  Right-click and select Paste - or - click on the Edit menu and select Paste;
(5)  Bitmap picture of a small envelope is pasted instead of MS Access database table data.
0
 
jhendersinAuthor Commented:
I am not holding down the Shift key during the Copy/Paste action.
0
 
BadotzCommented:
What version of Windows are you running?
0
 
jhendersinAuthor Commented:
XP SP2
0
 
BadotzCommented:
It beats the stuffing out of me - you don't have any special keyboard shortcuts turned on, like the dreaded StickyKeys?
0
 
jhendersinAuthor Commented:
No.  I cleared all of the Sticky Keys checkboxes and turned it off.  It's baffling me, too.  The only reason I am pursuing it is because it is the COO of our Firm and he wants it fixed.  He works in Access database files and Excel spreadsheets all day, and it has become extremely annoying for him.
0
 
BadotzCommented:
<slightly_off_topic>
I was contracting for a large manufacturing outfit, and the VP could not get his laptop to turn off. He collared me one afternoon and said, "You're an IT guy, right? I want you to fix my laptop. It won't turn off." I followed him onto his office - a space twice as large as the entire IT department - and he pointed the insubordinate machine out to me.

I went over to  the laptop and pressed the power key down, counted to 4, and when the machine turned off, I looked at him and said, "All fixed." He never bothered me again.
</slightly_off_topic>
0
 
jhendersinAuthor Commented:
It correctly pastes into Word, but not PowerPoint.  But your comment regarding Add-ins made me think.  I noticed the same little picture of an envelope on the toolbar in Excel.  That little picture belongs to an application called Workshare, a pdf-converter, meta-data removal application that is an Add-in to Excel on our computers.  I uninstalled Workshare and now it pastes correctly.

Thanks!
0
 
jhendersinAuthor Commented:
Good thinking!  This Expert's comments led to to the correct solution.
0
 
Jeffrey CoachmanMIS LiasonCommented:
jhendersin,

Great, glad I could help.

Is this "Paste over-ride" something that can be disabled in this add-in?
It sounds very annoying.
:-O

If not, then I suggest you contact the maker of this product and inform them of this issue.

JeffCoachman
0
 
jhendersinAuthor Commented:
The only configurable options within this application are the types of metadata that may be removed on internal and external emailed documents.  The toolbar appears to be the culprit, but there was no way to disable the toolbar only.  

The application itself does not have any kind of copy/paste functionality.  It just interferes with the Clipboard itself, in some way.  I could not discover in the registry, the Clipboard configuration, or any settings why/how it inteferes with the Clipboard.
0
 
Jeffrey CoachmanMIS LiasonCommented:
jhendersin,

Ok,

But I would still contact them, and make them aware of this issue.

Perhaps, they already have a patch for it.
Perhaps not, in which case your informing them of this issue might prompt them into patching it.

Good Luck

JeffCoachman
0
 
jhendersinAuthor Commented:
I will let our Workshare Support Group know about this.
0
All Courses

From novice to tech pro — start learning today.