MSA1000 not found by HP ACU

I have an HP DL380G4 with a FCA2101 HBA installed, connected to an HP san switch with an MSA1000 on it.  I also have installed a QLogic HBA in the DL380.
If I use SANsurfer, I can see the qlogic HBAs and the MSA1000, which to me would indicate they are all connected correctly.  However, if I use HP ACU as I need to configure the array, ACU does not find any storage controllers other than the internal RAID card.  I have tried connecting using the HP and the qlogic hbas with no luck.  I have installed all the HP utilities and drivers I can find for the hbas
I have tried numerous software/driver versions, but have had no luck.  The MSA1000 will ultimately be used on an ESX server.

Can anyone point me in the right direction as to how I might get this array detected?
inspire_itAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

andyalderSaggar maker's bottom knockerCommented:
Why not use the bootable support CD to set it up rather than the ACU? If you're going to run ESX you won't be able to use the ACU in future anyway. I think this is the right one;

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=12169&prodSeriesId=377751&swItem=co-47057-1&prodNameId=3302289&swEnvOID=1005&swLang=8&taskId=135&mode=4&idx=0
0
andyalderSaggar maker's bottom knockerCommented:
Well, did the latest version of the boot CD see it or not?
0
inspire_itAuthor Commented:
Hi,

the boot cd now sees the array, but won't let me configure it.  When I click on the array I get the following error:

The current array controller cannot be configured by this program.  the controller did not respond correctly to configuration commands.

possible reasons:
a hardware failure occurred
using an unsupported driver

I have swapped the HBA in the server, and connected to the second controller in the msa without any luck

any ideas?
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

andyalderSaggar maker's bottom knockerCommented:
I'd strip it down to single controller/single server/no switch setup and get rid of the redundant controller and HBAs and see if it still doesn't work. The firmware may be bad but that gets updated when you plug a spare in so both have the same software on now.
0
inspire_itAuthor Commented:
hi,

are you suggesting physically remove one of the controllers in the msa?  i have gone down the path of only using one server, one hba and no switch, connecting to only one msa controller, but havent actually removed the secondary controller from the box.
0
andyalderSaggar maker's bottom knockerCommented:
Yes, I'd remove the second controller from the MSA; get it working properly in a non-redundant config before you go for a dual-controller config.
0
inspire_itAuthor Commented:
no luck with this either - have removed the secondary storage controller from the msa, direct connected to the server and acu still gives me the same error....
0
inspire_itAuthor Commented:
have just run array diag and it shows the following - controller not configured, ris copies between drives do not match (screen dump attached)
arraydiag2.jpg
0
andyalderSaggar maker's bottom knockerCommented:
Well that's strange that the ADU sees the MSA but the ACU doesn't. RIS copies not matching at this time shouldn't be a problem since it's not configured yet but if you've put a random selection of old disks in it's possible that the controller is so confused it hasn't initialised properly.

I would take all the disks out, put some in a server and run system erase on it; this will completely erase the disks in that server (and the CMOS so expect to have to change a few settings to get it to boot from its old disks again) and try with just these disks in.

Is it still under warranty? you could log a call with HP, they have a tool to read the ADU for them.
0
inspire_itAuthor Commented:
after much aggravation i have managed to get acu to detect and configure raid.  however I can now not complete the configuration via the CLI (need to issue cli command to get it to talk to esx) - the serial cable is connected on 19200-8-n-1 and shows all the bootup information no problems.

However I cannot enter any commands into the CLI - any keystrokes are basically ignored - nothing appears on the screen when typed, nor any response.

Are there any tricks to using the CLI?
0
inspire_itAuthor Commented:
have managed to find out that the version of firmware i am running is a read only version.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.