CLI input to Enable SDM over HTTP Interface

I need to enable SDM through the command line interface.  I have configred enough to get FE0 to ping at 192.168.2.3 255.255.255.0.

My IT left and I need to reconfigure the router so reset it to Factory Defaults, I cannot access with SDM now, however, I can get through on the CLI Console port, or Telnet in through FE0.
Douglas_FagerstromAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

myin68Commented:
It would help to know what model router and IOS your working with.  Try:
http 192.168.2.0 255.255.255.0 inside
0
myin68Commented:
Also try: ip http server and use the ? to finish the command.
0
Douglas_FagerstromAuthor Commented:
I have a 1803W ISR Router with IOS 12.4
0
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Douglas_FagerstromAuthor Commented:
UPDATE:

I have gotten to the point where I enter the IP in SDM Launcher.  I get the first window that verifies Java, then the second popup comes up, normally here I would see a password prompt but instead I get a third popup window with this error:

Startup Error
has not been granted with the necessary privileges in order to startup successfully, or another unknown error occurred during startup.Please close all involved browser windows and try again by granting all requested privileges

I have tired the following fix from another posting:
try https://<ip address>

If http secure access is not enabled then do:

Router>enable
password:
router# config t
router(config)# Ip http secure-server
router(config)# ip http authentication local  (if using local authentication)
router(config)# end
router# wr mem

WIth no luck.
0
from_expCommented:
i suppose you have problems with SDM as an application, not with cisco configuration
0
Douglas_FagerstromAuthor Commented:
Maybe.  Not sure.  I can access one of our remote sites with SDM.
0
myin68Commented:
Make sure there aren't any popups being blocked, make sure you have a compatible java version for the SDM version, and always close all browsers before retying your login process.
0
Douglas_FagerstromAuthor Commented:
I have no antivirus, internet popup blocker is disabled and I have tried with SDM Launcher and through SDM installed on the router with the same error.
0
Douglas_FagerstromAuthor Commented:
I have also tried Java version 5 and 6.
0
myin68Commented:
Try from a different computer.  Any computer should be able to access the https:// address and be prompted for the credentials.  This way you'll narrow down the issue to a problem with your PC, or the router.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.