• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 347
  • Last Modified:

IIS' default page only viewable on local server

Hi,

We have enabled iis on a w2003 member server (it is also a wsus3 server).

When we enter the server's IP in a web browser at the server the default  web page displays correctly as expected.

However if we do the same from a workstation *at the same subnet*, the browser times out without being able to find the page.

From the workstation we can ping both the server's ip and its name so communication is ok.  No firewall.

How do we proceed to troubleshoot this....?

thanks for tips

Geir
0
geir056
Asked:
geir056
  • 3
  • 2
1 Solution
 
DarylxCommented:
It could be something to do with WSUS also using port 80.

Try changing the port number of the website to 81, then in a browser on another computer enter the IP address followed by the port number.  For example:

http://192.168.0.10:81/

Another thing to try is to add a host header to the website.  For example: www.yourlocaldomain.local.  Then add a host record named www in your local DNS zone.  Then enter www.yourlocaldomain.local in a browser on another computer.
0
 
geir056Author Commented:
Thanks for the suggestion.  I changed the port to 81, but when I wanted to open win firewall to enter an exception for port 81 it only allowed me to add programs, port number additions were grayed out - probably due to that those are GPO managed.  Just FYI port 80 is among the open ports in winfw.

I have also a WSUS issue (see my other open question) but this access problems was there before we deleted the wsus folder in IIS.  

Please elaborate more what yopu meant with your host header tip.  As this is for a n intranet server we cannot do local settings change like suggested for all workstations here.

Even though we have no dns problems I thought that the default page should be viewable to any clients when entering the IP address in my case..  Could it be anything with ntfs security rights on the www folder?

I have never encountered a problem like this with iis, it have always worked out-of-the-box

I hope to be able to track down the cause of this step by step too.

If it is WSUS3 causing the problem with 'blocking' port 80 I'd rather move wsus over to port 81.

regards

Geir
0
 
DarylxCommented:
In the properties of the web site, on the Web Site tab, click the advanced button.  Click add.  Select the IP address, port 80 and enter a name like www.something.local (make something.local the same as your local domain).  Then add a Host (A) record in your DNS zone.  The record should be named www and teh IP address should be the address of your webserver.  Then you should be able to access the site by entering www.something.local in a web browser.
0
 
geir056Author Commented:
Ahmmmm...

I just discovered that the windows firewall's Port 80 exception was not checked.  When I applied a local policy to get it editable and checked the exception I (of course) could access the iis web server from any workstation.  Sorry about my ignornace..

Geir
0
 
DarylxCommented:
Cool, glad you got it fixed.
0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now