Remote shutdown of win2k from a samba 3.0.26a pdc

I cannot perform remote win2k shutdown. Samba is a PDC. Tried:
net rpc shutdown computerName -Uusername

[2008/02/07 05:49:02, 0] rpc_client/cli_pipe.c:cli_rpc_pipe_open_noauth(2271)
  cli_rpc_pipe_open_noauth: rpc_pipe_bind for pipe \initshutdown failed with error NT_STATUS_NETWORK_ACCESS_DENIED
[2008/02/07 05:49:02, 0] utils/net_rpc.c:run_rpc_command(160)
  Could not initialise pipe \initshutdown. Error was NT_STATUS_NETWORK_ACCESS_DENIED

Shutdown of remote machine failed

result was: WERR_ACCESS_DENIED


Tried:
rpcclient -U userName -c shutdown computerName
Invalid command


If I only do 'rpcclient -U userName computerName' and then ? there isn't a single command listed in the SHUTDOWN section.


Any ideas?

LVL 1
mladjoAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

vishal_impactCommented:
WERR_ACCESS_DENIED is showing the user permission are insufficient login as root or administrator and then try
0
mladjoAuthor Commented:
I already tried as root, but got the same message.

I also tried with a local administrator account:
     rpcclient -W pcName -U administrator  pcName -c shutdown

but again:
    Invalid command
0
vishal_impactCommented:
Try this
ssh username@IP_ADDR shutdown -s

0
Introducing Cloud Class® training courses

Tech changes fast. You can learn faster. That’s why we’re bringing professional training courses to Experts Exchange. With a subscription, you can access all the Cloud Class® courses to expand your education, prep for certifications, and get top-notch instructions.

vishal_impactCommented:
By the way are you doin ssh if not try installin it and do it from there by command i mentioned that will work
0
mladjoAuthor Commented:
vishal_impact, thanks for the effort

I've managed to find the solution myself

1. I had to add allowed users (even root) to a win2k local security policy -> force shutdown from a remote system (which I did at the start)

2. for some reason it doesn't work with the netbios name so I had to use -I ip or -I dns name

maybe it gets confused because dns name is different than the netbio name...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
vishal_impactCommented:
HI
does that mean i have wasted my time on the issue
0
mladjoAuthor Commented:
Hi
no, it means that I am thankful for your effort, however your suggestions didn't help in solving the issue and someone else (in this case myself) found the solution

0
Vee_ModCommented:
Force accepted.
Vee_Mod
Community Support Moderator
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Server Software

From novice to tech pro — start learning today.