Want to talk a little about clockrate

I have two p2p between three routers.  The Main1721 in the code snippet has two Wic T1 DSU cards in it.  The remote sites have 1720's with one Wic T1 DSU cards in them.  We are running on ATT lines, I'm unsure what the clockrate config should be on each router.  My guess is on the Main1721 with both serial interfaces I should have
conf-int s/0 ... clockrate 1543000
conf-int s/1 ... clockrate 1543000

then on the remote sites I should have
conf-int s/0 ... clockrate line

Let me know how close I am.  I'm very new to this so I would like to know what I would actually need to type and what interface it needs to go on.
!
! Last configuration change at 16:51:03 UTC Mon Sep 3 2007
! NVRAM config last updated at 16:52:47 UTC Mon Sep 3 2007
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Main1721
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$1Uyi$iNUcNQt.NKYsesh9L04Xr/
enable password xxxx
!
no aaa new-model
ip subnet-zero
!
!
!
ip cef
!
!
!
!
class-map match-all VOIP
  match  dscp ef 
!
!
policy-map VOIP-Policy
  class VOIP
   priority 256
  class class-default
   fair-queue
!
!
!
interface FastEthernet0
 ip address 10.1.1.3 255.255.254.0
 speed auto
 full-duplex
 no cdp enable
!
interface Serial0
 ip address 192.168.1.20 255.255.255.0
 no cdp enable
 service-policy output VOIP-Policy
!
interface Serial1
 ip address 192.168.1.30 255.255.255.0
 no cdp enable
 service-policy output VOIP-Policy
!
router eigrp 1
 network 192.168.1.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.6
ip route 10.1.2.0 255.255.255.0 192.168.1.25
ip route 10.1.3.0 255.255.255.0 192.168.1.35
ip route 10.92.0.0 255.255.0.0 10.1.0.1
ip route 10.106.0.0 255.255.0.0 10.1.0.1
ip route 10.140.0.0 255.255.0.0 10.1.0.1
ip route 10.156.0.0 255.255.0.0 10.1.0.1
ip route 10.245.0.0 255.255.0.0 10.1.0.1
no ip http server
!
access-list 100 permit ip 10.1.0.0 0.0.1.255 10.1.2.0 0.0.0.255
access-list 100 permit ip 10.1.5.0 0.0.0.255 10.1.2.0 0.0.0.255
access-list 100 permit ip 10.92.0.0 0.0.255.255 10.1.2.0 0.0.0.255
access-list 100 permit ip 10.140.0.0 0.0.255.255 10.1.2.0 0.0.0.255
access-list 100 permit ip 10.156.0.0 0.0.255.255 10.1.2.0 0.0.0.255
access-list 100 permit ip 10.245.0.0 0.0.255.255 10.1.2.0 0.0.0.255
access-list 100 permit ip 10.106.0.0 0.0.255.255 10.1.2.0 0.0.0.255
access-list 101 permit ip 10.1.0.0 0.0.1.255 10.1.3.0 0.0.0.255
access-list 101 permit ip 10.1.5.0 0.0.0.255 10.1.3.0 0.0.0.255
access-list 101 permit ip 10.92.0.0 0.0.255.255 10.1.3.0 0.0.0.255
access-list 101 permit ip 10.140.0.0 0.0.255.255 10.1.3.0 0.0.0.255
access-list 101 permit ip 10.156.0.0 0.0.255.255 10.1.3.0 0.0.0.255
access-list 101 permit ip 10.245.0.0 0.0.255.255 10.1.3.0 0.0.0.255
access-list 101 permit ip 10.106.0.0 0.0.255.255 10.1.3.0 0.0.0.255
dialer-list 1 protocol ip permit
no cdp run
snmp-server community knb RO
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 password xxxxxx
 login
!
end
--------------------CROWNE1720-----------------------
 
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Crowne1720
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$.jko$KaVGx3eU9lLUv4vGm2exb0
enable password xxxxx
!
memory-size iomem 25
no aaa new-model
ip subnet-zero
!
!
!
ip cef
!
!
!
!
class-map match-all VOIP
  match  dscp ef 
!
!
policy-map VOIP-Policy
  class VOIP
   priority 256
  class class-default
   fair-queue
!
!
!
interface FastEthernet0
 ip address 10.1.2.1 255.255.255.0
 speed auto
 full-duplex
!
interface Serial0
 ip address 192.168.1.25 255.255.255.0
 no cdp enable
 service-policy output VOIP-Policy
!
router eigrp 1
 network 192.168.1.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.20
ip route 10.1.0.0 255.255.254.0 192.168.1.20
ip route 10.1.3.0 255.255.255.0 192.168.1.35
ip route 10.92.0.0 255.255.0.0 192.168.1.20
ip route 10.106.0.0 255.255.0.0 192.168.1.20
ip route 10.140.0.0 255.255.0.0 192.168.1.20
ip route 10.156.0.0 255.255.0.0 192.168.1.20
ip route 10.245.0.0 255.255.0.0 192.168.1.20
no ip http server
!
access-list 100 permit ip 10.1.2.0 0.0.0.255 10.1.0.0 0.0.1.255
access-list 100 permit ip 10.1.2.0 0.0.0.255 10.92.0.0 0.0.255.255
access-list 100 permit ip 10.1.2.0 0.0.0.255 10.140.0.0 0.0.255.255
access-list 100 permit ip 10.1.2.0 0.0.0.255 10.156.0.0 0.0.255.255
access-list 100 permit ip 10.1.2.0 0.0.0.255 10.245.0.0 0.0.255.255
access-list 100 permit ip 10.1.2.0 0.0.0.255 10.106.0.0 0.0.255.255
access-list 101 permit ip 10.1.2.0 0.0.0.255 10.1.3.0 0.0.0.255
dialer-list 1 protocol ip permit
snmp-server community knb RO
!
line con 0
line aux 0
line vty 0 4
 password xxxxxx
 login
!
end
------------North1720-------------------
 
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname North1720
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$z2FR$9.1XAcxjMEMKUhMFwf/Er1
enable password xxxxxx
!
memory-size iomem 20
no aaa new-model
ip subnet-zero
!
!
!
ip cef
!
!
!
!
class-map match-all VOIP
  match  dscp ef 
!
!
policy-map VOIP-Policy
  class VOIP
   priority 256
  class class-default
   fair-queue
!
!
!
interface FastEthernet0
 ip address 10.1.3.1 255.255.255.0
 speed auto
 full-duplex
!
interface Serial0
 ip address 192.168.1.35 255.255.255.0
 no cdp enable
 service-policy output VOIP-Policy
!
router eigrp 1
 network 192.168.1.0
 no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.30
ip route 10.1.0.0 255.255.254.0 192.168.1.30
ip route 10.1.2.0 255.255.255.0 192.168.1.25
ip route 10.92.0.0 255.255.255.0 192.168.1.30
ip route 10.106.0.0 255.255.255.0 192.168.1.30
ip route 10.245.0.0 255.255.255.0 192.168.1.30
no ip http server
!
access-list 100 permit ip 10.1.3.0 0.0.0.255 10.92.0.0 0.0.255.255
access-list 100 permit ip 10.1.3.0 0.0.0.255 10.106.0.0 0.0.255.255
access-list 100 permit ip 10.1.3.0 0.0.0.255 10.140.0.0 0.0.255.255
access-list 100 permit ip 10.1.3.0 0.0.0.255 10.156.0.0 0.0.255.255
access-list 100 permit ip 10.1.3.0 0.0.0.255 10.245.0.0 0.0.255.255
access-list 100 permit ip 10.1.3.0 0.0.0.255 10.1.0.0 0.0.1.255
access-list 100 permit ip 10.1.3.0 0.0.0.255 10.1.2.0 0.0.0.255
access-list 100 remark Access List Out
dialer-list 1 protocol ip permit
snmp-server community knb RO
!
line con 0
line aux 0
line vty 0 4
 password xxxxxxxx
 login
!
end

Open in new window

LVL 2
ibtayaAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
that1guy15Connect With a Mentor Commented:
No you should not need to configure both the clock rate and the clock source. One thing you can try is configure both sides with "service-module t1 clock source internal". If this works then i believe ATT is providing clocking. if not then set one side to "service-module t1 clock source line" and the other to 'service-module t1 clock source internal"
0
 
that1guy15Commented:
The clock rate only needs to be set on the DCE side of the line. Usually this is the ISP and not your router. Check with your ISP to verify this is correct and if not then ask what clock-rate they recommend for the T1.

Hope this helps
0
 
ibtayaAuthor Commented:
I've heard that term twice now, what is DCE?   This p2p is through ATT, do you know if they handle the clockrate?
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
that1guy15Commented:
The clock rate is always handled by the DCE (usually the ISP). DCE provides the clockrate to the DTE (which is usually you)

DTE = Data Terminal Equipment
DCE = Data Communications Equipment

With serial connections you always need to specify a DCE and a DTE. There are no commands to set a DTE you just need to specify the clock rate command on the DCE.

Check this link out it will give you a little more information.
http://ckp.made-it.com/dtedce.html

You will need to get with ATT to get all the configuration settings they require. Depending on the type of T1 connection you have this can very. Usually when you set up service they will give you a guide on configuring your router if not then you can request it.

Hope this helps
0
 
ibtayaAuthor Commented:
it does, I'm realizing more and more that I'm truly ignorant.  I'm on the router# and try dce ? and it brings back unrecognized, I try the same on router(config)# and router(config-int)# with the same result.  How do I set the DCE.  Also just got off the phone with ATT and they have a lot of requests for it but they don't have that document.  They told me its an ESF and B8ZS.  Which is really greek to me other than in the setup it asked me if that was it so I hit enter.
0
 
that1guy15Commented:
Usually on an interface you set the clockrate with the clock rate command

int s0
clock rate 54000
exit

But with the T1 you usually set it within the controller.

ex.
int s0
service-module t1 clock source internal
exit

ESF is your framing and B2ZS is your line code.
0
 
ibtayaAuthor Commented:
when I set the service module on the source internal side do I also need to set the clock rate?  Also what is the typical clock rate for a t1, I tried 1536000 but it didn't take it.  I set it to the one right below that as 1300000.  How wrong am I for doing that?
0
 
ibtayaAuthor Commented:
Thanks!!!
0
All Courses

From novice to tech pro — start learning today.