ftp data archive corrupted when downloaded from site

I have a site that we archive 4 directories to 4 different archives. After that, I create one archive with all 4 archives and then it is uploaded to an ftp server. To test the archive locally, the main archive extracts the 4 archives properly and each of the 4 archives extract properly.
Now when I download the one archive off of the ftp site, I can't open it. I downloaded a program called BitZipper and when I extract the archive, it tells me that the local header is damaged. I can still extract the 4 archives though. Each of the 4 archives extracted all give me the same error about the local header is damaged but I am able to extract all of the files.

My batch file is as follows
Pkzip25 -add -lev9 -rec c:\batch\data1.zip e:\data\*.*
(this is the same for the other 3 directories that I archive. Then I run this
Pkzip25 -add -lev0 -rec c:\batch\alldata.zip c:\batch\*.zip
I log into the ftp site
Delete the existing file
Set the data to binary
Put c:\batch\alldata.zip
johnbowdenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

warrenbucklesCommented:
Try changing your compression level from '9' to something less - maybe '5' for a trial.  I have seen problems with high compression on certain types of files - .psd (Photoshop) and .raw (raw image), for example.

wb
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
johnbowdenAuthor Commented:
I will try that
Thanks
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Protocols

From novice to tech pro — start learning today.