[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1130
  • Last Modified:

Why virtual machine cannot connect to any other machines?

VMware environment:
  NetApp SAN with dual iSCSI ports connecting separate Gigabit switch (sw-iscsi1, sw-iscsi2)
  ESX1, ESX2 (ESX3.0): CPU=8x2GHz cores, RAM=16GB
  Each ESX has two NICs connecting to separate Gigabit switch (sw-vm1, sw-vm2), two NICs connecting to sw-iscsi1 & sw-iscsi2. Both active; route based on originating virtual port ID.
  Production switch (sw-prod) has two ports connecting to sw-vm1, sw-vm2.
   physical machine (box-xp) connecting to sw-prod.
  HA and DRS configured.
  There are 10 virtual machines (vm).
  ESX1: 7 vms. eg. vm-dc1
  ESX2: 3 vms: Exchange server (vm-exch), vm-nt4, vm-citrix
Problem: Exchange server (vm-exch) could not send/receive email.
1st time:
  It seems to started  overnight (maybe around 10pm-1am)
  Facts:
    all other vm works fine
    vm-exch can ping its own ip but not any other (not sure if it ever got some reply among the timeouts).
    No resource contention.
  How it is resolved:
    1st time: Dell support changed Load Balance setting: route based on originating virtual port ID into IP hash. It started to work. (So I thought that was really the cause).

2nd time: Same problem happen again (4 days from the 1st time)
  It seems to started  overnight (maybe around 10pm-1am too)
  Facts:
    all other vm works fine
    vm-exch can ping its own ip
    "box-xp ping -t vm-exch" (on esx2) shows mostly timeouts but with a few reply with long delay
    "box-xp ping -t vm-nt4" (on esx2) shows reply with very few timeouts
    "box-xp ping -t vms on esx1" show all ok.
    No resource contention.
  How it is resolved:
    vmotion vm-exch off esx2 onto esx1: vm-exch started working right away.
    vmotion vm-exch back onto esx2 (3 hours later): still works so far.

I feel it seems to be related to the routing/switching in the virtual switch among the dual nic connecting to sw-vm1 and sw-vm2.

Q#1 How to check into the routing/switching table at the virtual switch level?
Q#2 What do you think cause my problem?
Q#3 What should I check now?
Q#4 What should I check when it happens next time?

Thanks a lot.
0
richtree
Asked:
richtree
  • 2
2 Solutions
 
Loren OkulySr. IT ManagerCommented:
How many ports are configured on your virtual switch. Now sure what it defaults to but I think the minimum is 8 and if set that low with 10 vm's??? could be your issue.
0
 
richtreeAuthor Commented:
virtual ports=56, more than enough for my vm for now.
0
 
AngelGabrielCommented:
Have you tried the VM on a diffrent system? I'm not an expert on VM network configuration, so, I'm just trying to help out :)
0
 
richtreeAuthor Commented:
Thanks.
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now