Unable to add to the server Junk E-mail Lists message pops up since migrating mailboxes to Exchange 2007

After running my mailbox on Exchange 2007 for several weeks with no problem,a fter migrating the rest of the company over (about 20 mailboxes), most, if not all, people started getting popup messages from Microsoft Office Outlook: "Unable to add to the server Junk E-mail Lists, you are over the size allowed on the server.  The Junk E-mail Filter on the server will be disabled until your Junk E-mail Lists have been reduced to the size allowed on the server."  We are running Outlook 2003 on Windows XP Pro SP2 and never had this when all of the mailboxes were on Exchange 2000.  I have not enabled Safe List aggregation or any other Exchange spam feature (at least that I was aware of)on the exchange server and I cannot find any documentation about blocked lists on the server.  We have TrendMicro ScanMail for Microsoft Exchange 8 running on the Exchange 2007 server (we also had TrendMicro antivirus & spam products on the Exchange 2000 server).
I have tried a number of things that were suggested by answeres to other similar questions on EE & other forums, but the only thing that worked (for my mailbox) was if I deleted all of teh blocked serder addresses in my Outlook (no big deal) AND unchecked "Also trust e-mail from my Contacts" - which IS a big deal, since if I have that unchecked, Outlook puts a lot of important real mail into junk - including plain text messages from people I know that is entirely safe & has nothing in it to indicate that it would be spam.
How do I administer the server junk email list this message refers to, since I cannot find anything about it in any Exchange 2007 documentation that I have searched?
I also tried creating and increasing several times the registry key suggested in Question ID:22553848 (which was for Exchange 2003, but I tried anyway)

Paul
PaulRAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
PaulRConnect With a Mentor Author Commented:
My understanding is that the Exchange 2007 anti-spam filters which we have installed is what they used to call IMF.
0
 
peakpeakCommented:
Trend Scam mail junk handling is a mess. Why don't you use Intelligent Message Filter? Free and extremely competent. As it's a Microsoft product it integrates 100% with  Outlook. Shut off Trend spam filter (keep the virus protection) and install IMF:
http://www.petri.co.il/installing_imf_with_exchange_2003_sp2.htm
0
 
PaulRAuthor Commented:
Installing Intelligent Message Filter does not appear to be an option as we do not have an Exchange 2007 Edge Transport Server, which is where all the documentation I see about it says it has to run.
We are using our pre-existing DeepSix spam appliance as an edge device because 1) The Edge Transport role cannot be installed on the same server as the other Exchange roles & 2) All Exchange 2007 roles must run on 64bit servers and we only have the one - which is running all of the other Exchange 2007 roles.

Are you trying to say that Outlook's junk e-mail filter is communicating with TrendMicro ScanMail?

Paul
0
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

 
PaulRAuthor Commented:
Still hoping to get some help on this issue with Exchange 2007.

Paul
0
 
PaulRAuthor Commented:
We have installed the anti-spam filters on our Excahnge 2007 hub transport and are still getting the message "Unable to add to the server Junk E-mail Lists, you are over the size allowed on the server.  The Junk E-mail Filter on the server will be disabled until your Junk E-mail Lists have been reduced to the size allowed on the server."

Any help anyone has would be appreciated.
0
 
peakpeakCommented:
IMF can be installed on Hub Transport if you do not have any Edge
0
 
GSHammCommented:
Why is this the accepted solution? This is not a solution at all. I also have this same issue and we do not use anything but Microsoft's anti-spam filters. Please help!
0
 
PaulRAuthor Commented:
Well, that is not the answer that was supposed to be accepted, which was posted but appears to be missing now.  The EE system does not appear to deal well with closing questions that the original questioner solved themselves.

Anyway, what you need to know is:
Find out who in your organization has the most contacts in Outlook.  Take the number of contacts that they have, multiply that by 200(the approximate number of bytes used per contact).  Then take this number and increase it to allow adding contacts without causing the message to reappear.
In the registry of your mail server browse to:
HKLM\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem
You will want to edit or create a new DWORD value named "Max Extended Rule Size" in the above key with the data being the number (in BYTES) that you came up with above.

For instance, our largest Outlook contacts contained 2177 contacts.
x200 = 435,400 bytes
We set our parameter to 1024000 (decimal) which stopped the message and should allow up to 5120 contacts in any person's Outlook.

This fix is mentioned for an Exchange 2003 server in Question ID:22553848, but that indicated that the value was in kilobytes.  After a week of phone calls to Microsoft support and escalating the problem several tiers, it was discovered that the value should be entered in bytes.  I don't know if that was a change from 2003 to 2007 or if it was always the case.

I hope this helps you and others and that this post stays put this time.

Paul

0
 
PaulRAuthor Commented:
PS.  Reboot the server after making the registry change.

Paul
0
 
insanegainCommented:
Thanks Paul, you are the true expert here.

insanegain
0
 
leokuznCommented:
Thanks Paul, your suggestions resolved my problems
Leonid
0
 
kbayerCommented:
I was banging my head against the desk trying to figure this one out after the Microsoft-approved fix didn't work. Why can't they update the Knowledge Base article to include the fact that it's bytes and not kilobytes?!

Thanks Paul!!

And this fix works for Exchange Server 2003 as well.
0
All Courses

From novice to tech pro — start learning today.