Cannot reach internet from behind ASA 5505 using Adtran Netvanta 3200 Router.

I am having trouble configuring a Cisco ASA 5505 from behind an Adtran Netvanta 3200.  The netvanta is currently our CSU/DSU/Router/Firewall.  I would like to use the netvanta just to terminate the T-1 and use the ASA 5505 for the firewall/vpn features.  I configured both how I thought they should be setup, however I cannot reach the internet from behind the ASA 5505.  I can however reach the Internet when I give my workstation on of my public IPs, so this tells me the Netvanta is at least configured enough for access.  Any insight would be appreciated.
 
Here are my configs for both devices...

Netvanta! NetVanta 3200/3205 Series Configuration
hostname "adtran"
enable password xxxx
!
username xxxx password xxxx
!
interface eth 0/1
  ip address  12.x.1.145  255.255.255.240
  no shutdown
!
interface t1 1/1
  coding b8zs
  framing esf
  clock source line
  tdm-group 1 timeslots 1-24
  no shutdown
!
interface ppp 1
  ip address 12.x.241.46 255.255.255.252
  cross-connect 1 t1 1/1 1 ppp 1
  no shutdown
!
ip route 0.0.0.0  0.0.0.0  12.x.241.45 (other side of T-1)
!
ip http server
ip http secure-server
!
line con 0
  login
  password xxxx
!
line telnet 0 4
  password xxxx
end

And here is the ASA 5505 Config I am trying to use....................................................................................

Result of the command: "show run"

: Saved
:
ASA Version 7.2(3)
!
hostname ciscoasa
domain-name default.domain.
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.3.2 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 12.x.1.158 255.255.255.240
!
interface Vlan3
 nameif dmz
 security-level 50
 ip address 10.9.2.1 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
 switchport access vlan 3
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain
access-list outside_access_in_1 extended permit tcp any host 12.x.1.146 eq smtp
access-list outside_access_in_1 extended permit tcp any host 12.x.1.146 eq https
access-list outside_access_in_1 extended permit tcp any host 12.x.1.146 eq www
access-list outside_access_in_1 extended permit tcp any host 12.x.1.146 eq pop3
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
no failover
monitor-interface inside
monitor-interface outside
monitor-interface dmz
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) 12.x.1.146 192.168.3.225 netmask 255.255.255.255
access-group outside_access_in_1 in interface outside
route outside 0.0.0.0 0.0.0.0 12.x.1.145 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.3.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
client-update enable
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.3.200-192.168.3.201 inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:13fc46654065dabdaca72c1b5c4d7b69
: end

Thank you in advance...
LVL 1
mediabsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JFrederick29Commented:
Everything looks good.  The only thing I see is that your DHCP server isn't enabled if you are attempting to use DHCP.

conf t
dhcpd enable inside
0
mediabsAuthor Commented:
I have DHCP being provided by a differnt source.  The configs both look correct to me, but every time I try, I cannot get out past the ASA.  I can ping the Ethernet interface of the Netvanta from the Outside interface of the ASA.  This isn't making sense, I must be missing something.
0
JFrederick29Commented:
Can you ping something on the Internet from the ASA?  Your ISP's router, their DNS servers?  The default gateway of the PC is 192.168.3.2 right?
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

mediabsAuthor Commented:
Ok, here is where I am at.

The default gateway of my local machine I am using for testing is that of the ASA.  I made sure that my DNS server has the correct default gateway as well.  When I make the changes and try to access the internet, it pulls up the website I entered after about 10 seconds (google.com).  Once I get to google, I can no longer pull up any other site, or even do a search and have it return a result.  It seems as if the internet connectivity dies after the initial connection.  I am sure it is not pulling up a cached page, as it makes no difference what the first page I load is.  Once I make the first connection after the ASA comes up, it will not let me go any further, all internet activity seems to get halted.

I can ping the other end of the PPP circuit from the outside interface successfully every time.  I cannot ping the other end of the circuit from my machine, but I think that is because icmp is blocked at the inside interface.

Any Ideas?
0
JFrederick29Commented:
Strange.  So, when you connect your PC to the router, everything works fine right?  It's only when you put the Firewall in place that you have this problem?  Are there any errors on the outside interface of the Firewall or inside of the router?
0
mediabsAuthor Commented:
If I give myself a Public static IP address and sit outside the firewall, I can browse the internet without issues (with my default gateway being the Ethernet port of the Netvanta).  It only becomes an issue once I get back behind the firewall with a 192.168.3.99 255.255.255.0 with a default gateway of 192.168.3.2.  I get out initially, but after that first connection is made, I can no longer access any other sites.  I am not using any proxy server or anything like that.  

My setup

ISP Router ---> PPP Line ----> Netvanta Serial -----> Netvanta Ethernet ----> ASA Outside ---> ASA Inside
12.x.241.45                              12.x.241.46                 12.x.1.145                  12.x.1.158            192.168.3.2
255.255.255.252                 255.255.255.252        255.255.255.240        255.255.255.240    255.255.255.0
0
JFrederick29Commented:
Yeah, so you can rule out the T1 and the Netvanta router and focus on the ASA.  Do you see errors on the ASA outside interface?

show int e0/0

I would also try rebooting the ASA just in case a process hung up on it...
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware Firewalls

From novice to tech pro — start learning today.