?
Solved

Problem With Bridging 2 PBX's via Cisco 2821's

Posted on 2008-02-07
2
Medium Priority
?
966 Views
Last Modified: 2013-12-27
Was a bit difficult to explain myself in part one but here goes; We are currently utilizing a NEC Neax 2000 pbx based system with analog phones (approximately 150phone/fax lines served via the PBX). I'll refer to this site as (Site 1). This is currently sitting on a standard T1. We have a co-location which is served NEC Electra 192 which has 17 extensions for voice and several for fax. This too is sitting on a standard T1 . I'll refer to the co-lo as Site 2. In between Site 1 and Site 2 we currently have a multi-link interface sitting on both sides (Site 1 = 2x1.54 and Site 2 = 2x1.54). The multi-link carries data from site 1 to site 2 and vice-versa. We're currently only utilizing about 35% of said Multi-link Interfaces.  We would like to be able to dial the extensions from site 1 to site 2 and vice-versa. We would also like the trunk from site 1 to carry the fax lines and voice calls for site 2. I am told that all that will be needed is a T1 Interface card for the Neax 2000, 2 additional WIC-T1CSU/DSU V2 cards for the 2821's that are hosting the multi-link interface, and a T1 card for the NEC Electra Elite 192. I was alos told that we can program the PBX's to work the way we want them to and then plug a patch cable from the NEC Electra Elite 192 Directly into the CSU/DSU card on the 2821 at Site 2  and vice-versa with the PBX located in site 1:

 _____________
|                          | Patch Cable
|    NEC               |    |       Cisco WICT1-CSU/DSU V2
| NEAX 2000       |    |             |
|    PBX     _____|    |             \/
|                | T1   |   \/      ____________________
|                |Card|--------|----|--  |                            |
 _____________          |Cisco 2821 (Site 1)          |
                                     |     |    |    |                       |
                                     ----------------------------------
                                                        ^
                                                        |
                                                        |
                                                        |
                                                        |
                                                        |
                                                        | <--------MPLS Multi-Link
                                                        |
 _____________                             |
|                          | Patch Cable        |
|    NEC               |  |       Cisco WICT1-CSU/DSU V2
|Electra Elite       |  |               |         |
| 192 PBX  _____|  |             \/         |
|               | T1     | \/       ____________________
|               |Card   |--------|----|--   |                        |
 ---------------------            |Cisco 2821 (Site 2)       |
                                       |    |       |        |              |
                                        ------------------------------                        

I can handle the confiugration of the PBX's but am lost when it comes to the config of the Cisco routers. We 're a non-for prof AIDS research org and we're low on funds; this is the cheapest solution I can get together and "cheap" at this moment in time is very good!.


Can someone help with the config of the routers? The "sh ver" on both routers is as follows:

Cisco IOS Software, 2800 Software (C2800NM-IPBASE-M), Version 12.4(3g), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2006 by Cisco Systems, Inc.
Compiled Mon 06-Nov-06 02:36 by alnguyen

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

Site_2 uptime is 5 weeks, 8 hours, 43 minutes
System returned to ROM by reload at 19:11:14 UTC Wed Jan 2 2008
System image file is "flash:c2800nm-ipbase-mz.124-3g.bin"

Cisco 2821 (revision 53.51) with 251904K/10240K bytes of memory.
Processor board ID
2 Gigabit Ethernet interfaces
2 Serial interfaces
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
62720K bytes of ATA CompactFlash (Read/Write)

Configuration register is 0x2102


The config's presently on the routers are as follows:

Site 1:

service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Site_1
ip cef
!
class-map match-all LAN-map
!class-map match-all EF-map
match access-group name LAN
!match access-group name EF
!
!
policy-map QoS
class  EF-map
priority 640
class class-default
bandwidth remaining percent 75
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
!

!
!
interface GigabitEthernet0/0
 description Site_1_to_LAN_via_1000BaseT_Etherchannel
 ip address 192.168.1.3 255.255.255.0
 duplex full
 speed 1000
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Multilink1
 ip address 64.xxx.xxx.xxx 255.255.255.252
 ppp multilink
 ppp multilink fragment disable
 ppp multilink group 1
 service-policy output QoS
!
interface Serial0/0/0
no ip address
 encapsulation ppp
 service-module t1 timeslots 1-24
 service-module t1 linecode b8zs
 ppp multilink
 ppp multilink group 1
!
interface Serial0/1
no ip address
 encapsulation ppp
 service-module t1 timeslots 1-24
 service-module t1 linecode b8zs
 ppp multilink
 ppp multilink group 1
ip classless
!
router ospf 1
 router-id 192.168.1.3
 network 192.168.1.0 0.0.0.255 area 0
 network 64.xxx.xxx.xxx 0.0.0.3 area 0
 redistribute static
ip route 0.0.0.0 0.0.0.0 192.168.1.2
!
ip access-list extended LAN

  permit ip any any dscp ef
  permit ip any any tos 5
!
ip http server
ip http access-class 23
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
access-list 23 permit 0.0.0.3 255.255.255.0
!
control-plane
!
!
scheduler allocate 20000 1000
!



Site 2:


Current configuration : 2990 bytes
!
version 12.4
!
hostname Site_2
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
!        
!
class-map match-all EF-map
 match access-group name EF
!
!
policy-map QoS
 class EF-map
  priority 320
 class class-default
  bandwidth remaining percent 75
!
!
!
interface Multilink1
 ip address xxx.xxx.xxx.xxx 255.255.255.252
 ppp multilink
 ppp multilink fragment disable
 ppp multilink group 1
 service-policy output QoS
!
interface GigabitEthernet0/0
 description Site_2_to_LAN_via_1000BaseT_Etherchannel
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 encapsulation ppp
 service-module t1 timeslots 1-24
 ppp multilink
 ppp multilink group 1
!
interface Serial0/1/0
 no ip address
 encapsulation ppp
 service-module t1 timeslots 1-24
 ppp multilink
 ppp multilink group 1
!
router ospf 1
 router-id 192.168.2.1
 log-adjacency-changes
 network xxx.xxx.xxx.0 0.0.0.3 area 0
 network 192.168.2.0 0.0.0.255 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 Multilink1
!
!
ip access-list extended EF
 permit ip any any dscp ef
 permit ip any any tos 5
!        
!
control-plane
!
scheduler allocate 20000 1000




Your help with this matter is greatly appreciated!!
0
Comment
Question by:TheLank
2 Comments
 
LVL 2

Accepted Solution

by:
estest earned 2000 total points
ID: 20846248
Here's an idea... maybe some other experts can give more details.

Put 1MFT cards in each router. Setup T1 QSIG trunks to each PBX. Setup POTS dial peers pointing to the PBX with appropriate extension rages.

Setup a VOIP dial peer for the call leg between the routers.

Of course, this doesn't explain how to configure the PBXs or how to ensure that the voice traffic gets priority on the MPLS connection (talk to your MPLS provider).

I know its not much, but maybe it'll get you started.
0
 

Author Comment

by:TheLank
ID: 20849462
Can anyne elaborate?
0

Featured Post

[Webinar] Improve your customer journey

A positive customer journey is important in attracting and retaining business. To improve this experience, you can use Google Maps APIs to increase checkout conversions, boost user engagement, and optimize order fulfillment. Learn how in this webinar presented by Dito.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As companies replace their old PBX phone systems with Unified IP Communications, many are finding out that legacy applications such as fax do not work well with VoIP. Fortunately, Cloud Faxing provides a cost-effective alternative that works over an…
If your business is like most, chances are you still need to maintain a fax infrastructure for your staff. It’s hard to believe that a communication technology that was thriving in the mid-80s could still be an essential part of your team’s modern I…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

607 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question