• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 12994
  • Last Modified:

configure a working certificate for OCS 2007

I installed OCS Standard Edition 2007 recently and during the install process requested a certificate from our certificate server.   When I attempt to start communicator and login the following error occurs: There was a problem verifying the certificate from the server.  I am on a domain using everything within it.  

I get this when I try and run a test
URL: https://185FS.boston.local/GroupExpansion/Int/service.asmx
Internal Error: TrustFailure
Suggested Resolution: Please set a valid certificate for IIS default web site. Additionally, ensure that certificate subject name is the same as web farm FQDN.

Not sure what I should be checking
0
gotti777
Asked:
gotti777
  • 9
  • 4
1 Solution
 
gotti777Author Commented:
I have done the create.  I am asuming the name can be anything Organization and Organization unit are company name and IT department.  As for Subject name its 185fs.boston.local    185fs is the name of the server that our OCS server is on(should it be something else).  Boston is are domain.  Subject Alt name is sip.boston.com   also  When I get to choose a certification authority I put in 185Mail.boston.local\ Pella Boston  which is the name of are main server (Mail- AD- DHCP-DNS) which was already filled in and I cant change. This server is not a domain Controler

I hit applied and everthing looks good.  

 

Now I go to Computer Management under default Website and add a existing Certificate i click on rthe one I made well 3  so far cause I want to make sure i did them right.   Port to 443 then finish. And I still get this error    

0
 
kristekCommented:
The certificate must have on the subjectName de pool name, not the server name (I'm not sure if the pool name can be on the alternateSubjectName of the certificate)

Also, make sure that your client computer trusts the CA itself. The certificate is issued by a CA but if the client doesn't trust this CA then you have a problem. You must had the CA certificate to the Trusted Root Certification Authorities on the client machine
0
 
gotti777Author Commented:
Dumb Question How do I make sure what the Pool Name is?
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
gotti777Author Commented:
If i try an enter anything other than 185fs.boston.local I get an    
The subject Name Does not Match the computer FQDN. Do you wish to continue?

So I assume 185fs Was right
0
 
gotti777Author Commented:
I also tried to export the certificate as an.pfx file from the computer where the Ocs resides and import it in the client machine in the trusted folder using mmc rebooted and nothing same thing
0
 
gotti777Author Commented:
I am running Standard edtion and when I try and make a cert

 

for the subject I put 185fs.boston.local If i try an enter anything other than 185fs.boston.local I get an    
The subject Name Does not Match the computer FQDN. Do you wish to continue?

 

185fs is the name of my OCS server.  boston is my domain, So I assume 185fs is the FQDN name.  

Is there a way to check that?

 

 

Yes my clients are all domain members..  I try and do auto and if tells me

---------------------------
Microsoft Office Communicator 2007
---------------------------
Cannot sign in because the server is temporarily unavailable. If the problem persists, contact your system administrator.
---------------------------
OK  
---------------------------


 

If I put in the IP address of my OCS Server under manual settings I get

 

---------------------------
Microsoft Office Communicator 2007
---------------------------
There was a problem verifying the certificate from the server. Please contact your system administrator.
---------------------------
OK  
---------------------------


You say I should my Pool FQDN to point the clients I tried using 185fs.boston.local I get the same error.  


0
 
kristekCommented:
on the client machine
START / Run / mmc
File Add/Remove Snap-In / Add / Certificates
Then on the certificates Tree goto "Trusted Root Certification Authorities" / "Certificates" and look for the certificate of your CA.

You should have something like
Issued to: PellaBoston
Issued by: PellaBoston

What this certificate does is ackowledge that you PellaBoston is a Trusted CA. If you don't have this certificate installed than all the certificates issues by this CA will not be trusted by the client machine.

To check your pool name
      Start / Run / dsa.msc
      View / Advanced Features
and navigate to
...,CN=Pools,CN=RTC Service,CN=Microsoft,CN=System,DC=....,DC=com
Check you poolname. Append the domain name to get the FQDN.
0
 
gotti777Author Commented:
Ok On your first part. I am not sure why I have to add the cert on the client if on the domain but after 2 week of install I will do anything to get this to work.  If I go to  Trusted Root Certification Authorities" / "Certificates on client machine find nothing with
Issued to: PellaBoston
Issued by: PellaBoston

I have a one with  

Issued to: 185fs.boston.local
Issued by: PellaBoston

But I imported this one that i made from the OSC  Server
also Say under status
This CA Root certificate is not trusted because it is not in the Trusted Root Certification Authorities store.

Should I be looking for one thats pellaboston , pellaboston?

On the second part are you saying 185fs.Boston.local is not my pool name?
If i try an enter anything other than 185fs.boston.local I get an    
The subject Name Does not Match the computer FQDN. Do you wish to continue?

I go to my  AD  expand ...     boston.local   /System   /Microsoft   /RTC Server   /Pools
I have a folder called 185fs with a Microsoft container






0
 
kristekCommented:
Regarding the pool name, I was just making sure that 185fs.boston.local is effectively your pool name. That is the case!

The Message "This CA Root certificate is not trusted because it is not in the Trusted Root Certification Authorities store." is what's actually giving your problems. As I've said before, the entity that generated the pool name certificate is not marked as a trusted entity.

On the client machine goto http://185Mail.boston.local/certsrv
Choose "Download a CA certificate, certificate chain, or CRL"
Choose "Download CA certificate chain"
The Right Click on the file you have just downloaded and "Install the Certificate"

ps: You can login to communicator if you manually choose the server and set TCP on Tools/Options/Advanced in communicator (The cerfificate is required only for TLS). Your server must also be configured to accept TCP connections (usually port 5060)
0
 
gotti777Author Commented:
By the way thanks for your help Kristek I have been working on this for a week already. I did what you told me and downloaded the cert chain and now my 185fs.boston.mail cert that originally said not trusted is now ok. I rebooted server and client and still same error.

At this point I can care less about using TLS because this is only going to be an internal system. Security isn't an issue till I someone decides to let outsiders in.  I know how to change clients to TCP how do you change it on the the server  
0
 
kristekCommented:
On MOCS console, right click on your server (185fs.boston.mail). On the General tab click Add and choose TCP as Transport.

I find it strange that manually configuring the server as 185fs.boston.mail on OCS Client, and choosing TLS doesn't work. Note that you must put the server name no the server IP your the certificate will fail
0
 
gotti777Author Commented:
OMG after putting in 185fs.boston.local and TLS. It connects fine, go figure.   but i have to log in using
email glebron@boston.local   instead of glebron@pellaboston.com.  After I configured Ad as glebron@pellaboston.com I have to go into the server and change it to local. for it to work but thats a new issue I will start a new tread.  Thanks for helping me on this one!!!
0
 
gotti777Author Commented:
thanks for being patient and clear with me  
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 9
  • 4
Tackle projects and never again get stuck behind a technical roadblock.
Join Now