Default email account setting automatically changing back to exchange server

I have a small office nework running SBS2003 with exchange server.  For reasons beyond my control the client is not using exchange and their mx records do not direct incoming mail to their exchange server.  Rather, they receiving and sending email via outlook 2003 by POP to a couple of different hosting accounts.  Because of this I have the pop account set as the default account in outlook.  However, the system for some reason keeps changing the default email account back to the exchange email account. As a result when email is sent they receive an undeliverable mail SMTP error 550 unable to relay email error message.  As long as messages are sent via the POP3 email account everything is fine, but since outlook changes the default account back the problem keeps coming back.  Any advice would be appreciated.
cliffmeyersAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
iFrogConnect With a Mentor Commented:
I solved my issue by removing the small business server setup script from running when the computer was rebooted. This solved outlook from constantly switching and annoying Vista compatibility errors.
0
 
isaman07Commented:
Outlook is running on the server or workstations? Do users have roaming profiles configured or not?

Harout
0
 
cliffmeyersAuthor Commented:
Outlook is running on the client workstations.  The clients (outlook) were previously using exchange to receive exchange mail but have not been for several months now.  Recently, they changed their ISP to SBCGLOBAL.NET.  As long as you manually change the POP mail account in the client's outlook to being the default mail account everything works fine.  However, outlook keeps changing the default account back to the exchange account and the outgoing messages fail when it does.  I am not familiar with the roaming profiles configurations.
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
isaman07Commented:
OK, in ADUC right click on a username and choose properties---->profile, is there anything entered in the profile path field? Or are there any logon scripts?
0
 
dexterhomeCommented:
This issue could simply be a registry issue when saving the profile, as should apply your changes and save. It could also be that the outlook client is also still actively connecting to the exchange server for other items and is being modified by exchange. there are a few ideas i could advise trying. 1. have user log on to another computer., this should then create a new profile and will either fix the issue or highlight it as not being user/machine specific. 2.change the sbs server settings to download pop mail from ips server, create collection accounts for all required email accounts and have exchange distrobute them, remove the direct connections from outlook. The second is not always recomended, but once setup and working for you, can very easily be changed to full smtp settings. Hope this helps.
0
 
cliffmeyersAuthor Commented:
There is nothing in the profile path. Only SBS_LOGIN_SCRIPT.bat in the logon sript. thanks
0
 
cliffmeyersAuthor Commented:
Ok, I signed this user on to another client workstation and open and configured his pop account.  
Unfortunately, after logging off and then logging him back on to his workstation outlook had changed his default mail account back to exchange.  So everytime logoff occurs the default account changes back to the exchange account.  
0
 
isaman07Commented:
OK just to make sure of something. Create a new user account and logon a workstation, configure outlook for pop then check if the same thing will happen to the new user. What i'm trying to find out, is if there a local profile configured, since there is no roaming profiles.
Your problem is a profile problem or this is maybe done by a script or registry key, where any user that logsin, outlook will be configured automatically for exchange server.
0
 
isaman07Commented:
Could you check what's in the SBS_login_script.bat ?
0
 
cliffmeyersAuthor Commented:
OK, I'll add the new user and see.  The SBS_login_script.bat is:

\\WTLSERVER\Clients\Setup\setup.exe /s WTLSERVER

thanks
0
 
cliffmeyersAuthor Commented:
I added a new user and configured a pop mail account in outlook on another workstation.   Tested to make sure it works.  Whenever outlook is closed, client logs off, and then logs back in, outlook automatically makes the exchange mail account the default user.
0
 
cliffmeyersAuthor Commented:
Oh, I will also add that I did receive this error message once during logon on the other workstation.  Don't know if it's related or not:

Error in registry for extension "Exchange Extensions;?" The syntax of format of the registry entry is incorrect.  Check the registry settings and compare the registry for this extension to other extensions in the registry.
0
 
isaman07Commented:
What is the WTLSERVER mentioned in the login script?
0
 
cliffmeyersAuthor Commented:
It is the name given to the server computer.   thanks
0
 
dexterhomeCommented:
I have just checked your original question and noticed that the users no longer use the exchange server, but it defaults back.. The answer may be in the question. do they use the exchange side of outlook OR do they just use it as a stand alone for the pop mail. If only pop mail is used then just remove the exchange link from the local machine in control panel (mail). This will then ask outlook to create a new account on startup and advise only pop mail. Another issue may be that the local machines do NOT have outlook installed, but have used the SBS outlook exchange client plugin, which is part of the sbs server and may force exchange to be the default link.
0
 
cliffmeyersAuthor Commented:
Thanks very much for your help.  Outlook was installed on each workstation as part of the Microsoft Office 2003 suite.  They have used exchange mail before and if they can get a corporate decision settled may use it again.  Right now they only only use POP.  I'm not sure if I remove exchange from their mail account if everything will work the same on their calendar.  I did edit the profile in control panel to see if changing the default profile helped but it seems to still revert the default account back to exchange.  Anyway, I went ahead and configured a SMTP connector in exchange virtual server to send out this POP mail via their new ISP smart host and relaying is working now.  Unfortunately, I am now getting pesky administrative notications (relaying successful) sent back to the sender's mailbox.  Thanks again, I'll see how this works for now.
0
 
iFrogCommented:
I have the same sitution going on.  I have a small office that uses a pop email account since we do not have a static IP.  We also have exchange server set up because they need to share calendars and contacts.  Is there a fix for outlook defaulting back to exchange server?
0
 
cliffmeyersAuthor Commented:
I never found a way to keep the default mail account from changing back to exchange server.  
The workaround I used was adding a SMTP Connector for outbound emails in exchange virtual server so that the exchange mail account, when defaulted back to, would send or "relay" the outbound emails.  You can find some info on doing that here: http://www.christensen-software.com/support/config_exchange_2003.htm 
0
 
RedshelfCommented:
Has anyone managed to find a solution to changing the deafult exchange account. we are trying to connect to exchange over a vpn to an external office, however when we put in the oher servers nme etc.... once outlook is initiated then it automatically reverts back to the local exchange server. cant see anything in group policy and suggestions regarding using hhtp have failed.... any help would be aqppreciated
0
 
Vee_ModCommented:
Closed, 125 points refunded.
Vee_Mod
Experts Exchange Moderator
0
 
rhgundersonCommented:
Another way to prevent SBS from changing the default email client is to add this key to the client PC:

HKLM\Software\Microsoft\SmallBusinessServer\ClientSetup
Name: NoTransportOrder
Type: REG_DWORD
Data: 1

This keeps the server from messing with the order of the email accounts you've set up. Downside is this has to be done for each client.
0
All Courses

From novice to tech pro — start learning today.