Hosts on DMZ interface cannot load web pages - ASA

I have been wracking my brain to make this work and need some peer review.  Hosts that are on the DMZ interface cannot access web pages (internal hosts can).  I have been attempting to do this to an IP address so I doubt DNS is an issue.  http://192.245.12.31/.

This is a very basic set up and is in my lab, so showing IP addresses is not a problem.

What am I missing?
: Saved
:
ASA Version 7.2(3) 
!
hostname fw01
domain-name ****.com
enable password ****** encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.5.213 255.255.255.0 
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute 
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 ip address 10.200.1.214 255.255.255.0 
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
 switchport access vlan 2
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
 switchport access vlan 3
!
interface Ethernet0/6
 switchport access vlan 3
!
interface Ethernet0/7
 switchport access vlan 3
!
passwd ****** encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name pryor.com
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
access-list dmz_access_in extended permit ip 10.200.1.0 255.255.255.0 any 
access-list no-nat-dmz extended permit ip 10.200.1.0 255.255.255.0 192.168.5.0 255.255.255.0 
access-list no-nat-dmz extended deny ip any any 
pager lines 24
logging enable
logging buffered informational
logging asdm informational
mtu inside 1500
mtu outside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
nat (dmz) 0 access-list no-nat-dmz
nat (dmz) 1 10.200.1.0 255.255.255.0
nat (dmz) 1 0.0.0.0 0.0.0.0
static (dmz,inside) 10.200.1.0 10.200.1.0 netmask 255.255.255.0 
access-group dmz_access_in in interface dmz
route outside 0.0.0.0 0.0.0.0 65.28.44.1 1 track 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 172.20.20.0 255.255.252.0 inside
http 10.200.1.0 255.255.255.0 dmz
http 192.168.5.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
sla monitor 1
 type echo protocol ipIcmpEcho 65.28.44.1 interface outside
sla monitor schedule 1 life forever start-time now
!
track 1 rtr 1 reachability
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.5.220-192.168.5.240 inside
dhcpd enable inside
!
 
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map 
  inspect ftp 
  inspect h323 h225 
  inspect h323 ras 
  inspect rsh 
  inspect rtsp 
  inspect esmtp 
  inspect sqlnet 
  inspect skinny 
  inspect sunrpc 
  inspect xdmcp 
  inspect sip 
  inspect netbios 
  inspect tftp 
  inspect http 
!
service-policy global_policy global
prompt hostname context 
Cryptochecksum:7023728842c9c256eb4e0acd075514e2
: end
asdm image disk0:/asdm-523.bin
no asdm history enable

Open in new window

markrsullivan1Asked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
batry_boyConnect With a Mentor Commented:
Try putting in these commands:

no nat (dmz) 0 access-list no-nat-dmz
clear configure access-list no-nat-dmz
no static (dmz,inside) 10.200.1.0 10.200.1.0 netmask 255.255.255.0
no access-group dmz_access_in in interface dmz

The first 3 commands really shouldn't be there in your environment and the last command is only needed if you are going to allow traffic from the dmz to higher security level interface.  The only higher security level interface you have on this firewall is the inside interface on VLAN1, but because you apparently have the base license on this 5505, the command "no forward interface Vlan1" is going to prohibit traffic from the dmz to the inside even if you did want to allow it...your license won't permit traffic from the 3rd VLAN (the dmz) to both of the other VLAN interfaces, just 1 of the other interfaces and you get to decide which of those interfaces to allow.  In this case, you are allowing traffic to go from the dmz to VLAN2 which is the outside.
0
 
markrsullivan1Author Commented:
OK...I'm oficially the biggest idiot on the planet.  First, thank you for your help.  Second...then next time I forget to put a default gateway from my host to the FW, I'm gong to go drink myself into oblivion.

Thanks again.
0
 
batry_boyCommented:
Drink one for me...;)
0
All Courses

From novice to tech pro — start learning today.