[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 5678
  • Last Modified:

Exchange not delivery e-mail to mailboxes.

Around noon today Exchange 2003 SP2 stopped delivering e-mail to mailboxes.  In the message tracker, the last entry for messages is: "SMTP: Message queued for local delivery".  This is happening for all mailboxes.  I checked the event log and saw that I was getting the error Event ID 9791 from MSExchange IS Mailbox: "Cleanup of the DeliveredTo table for database 'First Storage Group\Mailbox Store (DNASERVER)' was pre-empted because the database engine's version store was growing too large. 0 entries were purged."

I restarted all Exchange services.  When I did that, a few e-mails that were hung up pushed through, but now they are all hung up again.  I am not receiving the same error in the event log though.

Any ideas on how to find out why the mail is not being delivered?  This issue is extremely urgent for us.

Thanks
0
I_play_with_DNA
Asked:
I_play_with_DNA
  • 9
  • 7
  • 7
1 Solution
 
jderaCommented:
Check how big your exchange database is, it sounds like you hit the limit on size.
0
 
I_play_with_DNAAuthor Commented:
Update:  Error Event ID 9791 from MSExchangeIS Mailbox has started again.  Once every minute the error appears in the event log.

Event Type:      Warning
Event Source:      MSExchangeIS Mailbox Store
Event Category:      Background Cleanup
Event ID:      9791
Date:            2008-02-07
Time:            3:28:36 PM
User:            N/A
Computer:      OURSERVER
Description:
Cleanup of the DeliveredTo table for database 'First Storage Group\Mailbox Store (OURSERVER)' was pre-empted because the database engine's version store was growing too large. 0 entries were purged.

For more information, click http://www.microsoft.com/contentredirect.asp.
0
 
jderaCommented:
How big is the database right now?  Search for database name should be priv1.edb
0
Easily manage email signatures in Office 365

Managing email signatures in Office 365 can be a challenging task if you don't have the right tool. CodeTwo Email Signatures for Office 365 will help you implement a unified email signature look, no matter what email client is used by users. Test it for free!

 
I_play_with_DNAAuthor Commented:
@jdera

How do I check the total size of the database?  (I'm not the usual exchange admin.)
0
 
I_play_with_DNAAuthor Commented:
Database is 20.4 GB (size of priv1.edb).  Our limit is currently set to 35 GB in the registry.
0
 
isaman07Commented:
How come it showes 35GB? E2k# sp2 has a database size of 75 GB.
0
 
jderaCommented:
Oh boy, you must be having fun.  In that same folder as priv1 there should also be a pub1.edb.  What is that size?
0
 
jderaCommented:
It shows 35GB because someone set it to that level with SP2 that was a new option.  You are correct 75GB is the limit unless some wants to make it smaller due to disk space issues, etc...
0
 
jderaCommented:
This is how to correct your issue:

Please read:

http://support.microsoft.com/kb/919417

0
 
isaman07Commented:
OK what are the sizes of the following
priv1.edb,
pub1.edb
priv1.stm
pub1.stm
0
 
jderaCommented:
Do what I said above and all should be well.
0
 
I_play_with_DNAAuthor Commented:
@jdera & isaman07

I think Exchange 2003 SP2 had a DEFAULT size of 18 GB, but you can increase it to 75 GB by changing the registry key.  Several months ago we increased it to 35 GB from the 18 that was set when SP2 was installed.

@isaman07

priv1.ebd  20.4 GB
priv1.stm  9.7 GB
pub1.edb  192 KB
pub1.stm  25 KB



0
 
I_play_with_DNAAuthor Commented:
Oh, and e-mails are SLOOOOOOOOWLY trickling though.  There is about a 20-30 minute (or more) delay between receipt of an e-mail and delivery to the mailbox.

I'll take a look at the KB article jdera posted.
0
 
isaman07Commented:
Do what he says above or else!!!
0
 
jderaCommented:
Ha....Ha....Ha...sorry, did not mean to come across that way......
0
 
isaman07Commented:
lol, just kidding, but the article looks and sounds very logic.
0
 
I_play_with_DNAAuthor Commented:
I just sent out an e-mail saying that I will be taking Exchange down at 6 pm to apply the Hotfix mentioned the above-posted KB article.  Too bad it will take longer than that for the e-mail to reach users' mailboxes!

Oh well......warnings are overrated.
0
 
I_play_with_DNAAuthor Commented:
Ok, before installing the hotfix, I blocked all incoming e-mail (so our ISP is simply queueing it right now) and rebooted the server.  The error is no longer appearing in the event log, but the problem still exists and appears to be getting worse.  The delay for message delivery is very long now, and I can't be sure that messages will be delivered at all.  

In Exchange System Manager, under Queues, I could see all of my test e-mails sitting in the local delivery queue.  I used the 'Find Messages" function and deleted all of the e-mails that showed up.  But now ESM tells me that there is 1 message in the Local Delivery queue (total message size 5 KB) even though Find Messages shows nothing.  It looks like something is hung up inthe queue, but I can't find it!

Any ideas?
0
 
isaman07Commented:
Try installing a new smtp virtual server see how it will handle it. People had similar problems and a new smtp virtual server solved problems. Check the link
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23120530.html
0
 
I_play_with_DNAAuthor Commented:
Ok, before I try a new SMTP server, I just had a look at the queue folder (D:\Program Files\Exchsrvr\Mailroot\vsi 1\Queue) and there is a single .EML file in there that is 687 MB (YES!  687 MB in size). I tried deleting it, but it's "in use".  I suspect that this has something to do with my problem.  Any idea what might be using this file and how to delete it (or move it)?
0
 
isaman07Commented:
Damn, just coupple of days ago i had someone who had the exact same problem. Stop all exchange related services and delete that file, then restart all services back. Damn.Some moran tried to send a big attachment by email which resulted denial of service on your smtp virtual server.

Harout
0
 
isaman07Commented:
Or alternatively, in ESM, right click your virtual smtp server---->find messages---->highlight the message and choose delete with NDR or no. Another way is to rename your queue folder let's say to queue1 and then create a new folder and name it queue.

Let me know.
Harout
0
 
I_play_with_DNAAuthor Commented:
Well, this wasn't exactly the solution to my problem, but the link you provided gave me the idea of checking my queue folder where I found that honking-big e-mail (687 MB!) that my Exchange Information Store service was choking on, so the points are yours.
0

Featured Post

Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

  • 9
  • 7
  • 7
Tackle projects and never again get stuck behind a technical roadblock.
Join Now