Login Script cached?

We recently modified a login script to call and application that will merge a registry key for a piece of software deployed in the company.  

The first version of the app being called generated an error on login. After the app was modified and fixed some users still experience the error even though if the login script is run manually or another user logs in to the  same box it does not occur.

Is there a place that the scripts are being cached or the app itself? any way to clear this out?
LVL 1
yossefheskielAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Danny ChildIT ManagerCommented:
logon scripts are shared between all the DCs that are available, in the NETLOGON share.

on the one that shows the out of date scripts, drop to a command prompt and do
SET LOGONSERVER
and it will tell you which server authenticated that login.

After you change a script, you'll need to wait for replication before all servers pick it up - can take up to an hour.  

hth, Danny
0
Danny ChildIT ManagerCommented:
to clarify, when I said "on the one", this means of course "on the PC"...!
0
yossefheskielAuthor Commented:
The Login script has been replicated already to all DC's. This is a case where if you run the script from any DC manually it runs no problem. Also if it runs on login for most users from any DC it runs no problem. Only a few users are having the problem on login.

I had already checked their logonserver and run the script from it manually and it worked, and also set the logon server to a different DC and it still got the error belonging to the old app.
0
kmarfCommented:
I'm having this same issue, and I think there has to be some kind of cacheing of the login script.  We recently separated off into our own domain, and some users are still running the old login script.

Yosssef - is it the same users every time for you?  On mine, it's random people getting the wrong script on random days.  Though some users never seem to get it.  I tried SET LOGONSERVER as suggested above, and it reports the correct server, which has the correct version of the script.

I'll post here if I find a solution, and keep checking to see if someone here solves it first!
0
yossefheskielAuthor Commented:
My users were getting it regardless of the logonserver I set. In the end I renamed the application I wanted them to get and I had to reboot my dc's to remove the old application. Apparently the file got locked and would not delete for anything even though system manager or taskmanager did not show the application in use. I downloaded a program called lockcopy or something like that to process a delete of the file on reboot.

Turns out the problem with the programs was the same with the new version as the old version. Users were getting an error when I called a program to merge a registry key, saying that it could not execute the external program regedit. The cause I figured out was I needed to have the login script copy the file locally instead of having it execute from the DC.  For me the problem is resolved.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows XP

From novice to tech pro — start learning today.