Windows Service Greyed Out - Cannot Attach to Debug

I have created a Windows Service using Visual Studio 2005.  I have also installed the service via "installutil" and started the service without problem.  When I try to attach to the service in order to debug the service is greyed out and therefore will not allow me to attach.

Why is this service greyed out?
ccnetmonAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Carl TawnSystems and Integration DeveloperCommented:
Did you install the release version of your service or the debug version ?
0
ccnetmonAuthor Commented:
I installed the debug version.
0
Carl TawnSystems and Integration DeveloperCommented:
In that case, in the Attach to Process dialog, tick the "Show processes from all users" option and you should then see an non-greyed version which you can attach to.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
.NET Programming

From novice to tech pro — start learning today.