Routing issue to external recipients in Exchange 2003 to Exchange 2007 migration

I am in the process of migrating a client to Exchange 2007.  I have a legacy Exchange 2003 server which has 150+ mailboxes on it.  I moved one test mailbox to the new Exchange 2007 server.  When I send messages from the Exchange 2007-hosted mailbox to INTERNAL recipients, they receive the messages with no problem.  Mail sent to EXTERNAL addresses outside the organization gets stuck in the "Unreachable Domain" queue on the 2007 server and ultimately generates a NDR.

Users on the 2003 server function normally both ways.  I created a Send Connector on the Organization Hub Transport tab, telling the 2007 server to use the 2003 server as a smart host.  Then the 2007 user could send out to the Internet, but suddenly nobody on the 2003 server could because the servers started complaining that I'd created a loop situation.  I've changed it back to the way that it was and the mail for the 2003 mailboxes is working normally now.

I need to do this migration slowly, so I really need these servers to coexist peacefully for a while.  Can anyone help?  
requestechAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
requestechConnect With a Mentor Author Commented:
I found an article on Technet that gave me what I needed to make this work.  The article is entitled "Planning for Coexistence" and is located here:

http://technet.microsoft.com/en-us/library/aa998186(EXCHG.80).aspx

There were specifically a couple of links in this article that I followed and once I did both of these steps, both Exchange Servers started sending and receiving with no problem, internally and externally.  The first is entitled "How to Suppress Link State Updates" and is located here:

http://technet.microsoft.com/en-us/library/bb738138(EXCHG.80).aspx

As you can see in this article, in the scenario I'm using, you must first suppress link state updates on the Exchange 2003 server by performing the following steps:

1.  Open Registry Editor.
2.  Locate HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RESvc\Parameters.
3.  Right-click Parameters and select New | DWORD value. Name the new DWORD value SuppressStateChanges.
4.  Double-click SuppressStateChanges.
5.  In the Value data field, enter 1.
6.  Close Registry Editor and then restart the Simple Mail Transfer Protocol (SMTP) service, the Microsoft Exchange Routing Engine service, and the Microsoft Exchange MTA Stacks services for the change to take effect.

Once those steps are completed, then follow these steps from an article entitled "How to Configure Internet Mail Flow Directly Through a Hub Transport Server":

1.  Create a Send connector on the Hub Transport server to send e-mail to the Internet by performing the following steps:
2.  Open the Exchange Management Console. Expand Organization Configuration, click Hub Transport, and then in the action pane, click New Send connector.
3.  On the New SMTP Send connector wizard Introduction page, in the Name field, type a unique name for the connector. From the Select the intended use for this connector drop-down list, select Internet, and then click Next.
4.  On the Address Space page, click Add. In the Add Address Space dialog box, type "*", and then click Next.
5.  On the Network Settings page, select Use Domain Name System (DNS) to route mail automatically. Select the check box to Use External DNS Lookup settings. Click Next.
6.  On the Source Server page, click Add. In the Select Hub Transport and subscribed Edge Transport servers dialog box, select one or more Hub Transport servers in your organization, click OK, and then click Next.
7.  On the New Connector page, click New, and then on the Completion page, click Finish.
8.  Modify the default Receive connector to allow anonymous connections by performing the following steps:
9.  Open the Exchange Management Console. Expand Server Configuration, click Hub Transport, and in the work pane under the Receive Connectors tab, select the Default Server Name connector. In the action pane, click Properties.
10.  In Connector Properties, select the Permissions tab.
11.  Select Anonymous Users to add anonymous permissions. Click OK.

Once I completed all these steps, mail started flowing properly in both directions.
0
 
cshockeyCommented:
Personally I would start with Exchange Best Practices Analyzer and make sure everything is configured correctly.  Download at (http://www.microsoft.com/downloads/details.aspx?FamilyID=dbab201f-4bee-4943-ac22-e2ddbd258df3&DisplayLang=en)

1) Verify firewall port rules are established correctly outbound (TCP 25, UDP/TCP 53) from the IP's of your exchange servers.
2) Then I would check to make sure DNS was functioning correctly from all your 2007 servers.  This includes reverse DNS lookups for your external IP's associated with your new Exchange instance (Set this up through your ISP).  A quick way to test MX reslution is...START--> Run --> "CMD"...nslookup --> set type=mx --> {yourdomain.com}...{someotherdomain.com}...you should see mx records reporting for both.
0
 
requestechAuthor Commented:
The only issue the BPA reports is that the paging file is larger than the physical memory on my 2003 server.  

This organization uses a Linksys router which allows outbound traffic to flow freely, so there are no outbound ports blocked.  I don't have a separate external IP for the new Exchange server.  We just have a single static IP in place.  I just want the new Exchange server to route its outgoing mail through the 2003 server.  Is there any way to accomplish that without creating a loop?
0
 
cshockeyCommented:
Nice work.  This should help a lot of folks.  In place parallel exchange migrations are tricky.
0
 
Vee_ModCommented:
Closed, 500 points refunded.
Vee_Mod
Community Support Moderator
0
All Courses

From novice to tech pro — start learning today.