• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 946
  • Last Modified:

I am trying to turn off the on screen keyboard.

I have already done the steps that are posted but no luck. I have also gone into the start up section and there is nothing related to the easy access program . I even tryed msconfig and looked in startup but i still do not see anything.
Any ideas
  • 2
2 Solutions
Try looking for osk.exe in the task manager and end the process.
There are two different keyboards. One is the Accessibility one, and the
other is the slicker looking TabletPC one, which has tabs for handwriting
input as well.

Which one have you got? The TabletPC keyboard appears on the logging in
screen when you have a graphics tablet plugged in.

In fairness to myself :-) that's the same as my first suggestion: go to
Control panel, Ease of Access, Use computer wthout mouse or keyboard. Still,
good to have it double-checked.

if you have checked all those things and nothing works, I have 2 further

1) download and run the "autoruns" utility:
Autoruns will show you *everything* that is configured to run automatically
on your machine.

2) As Synapse suggested: on a Tablet PC, having an onscreen keyboard is
normal. In Vista, the Tablet PC extensions will be installed by default,
whether you have a Tablet PC or not. If you have a graphics tablet or
similar device, the Tablet extensions will think they are on a Tablet PC and
cause the Tablet Keyboard to become active. If you don't actually want to
use any of the Windows Tablet extensions, you can simply remove them. Go to
Control Panel, Programs and Features, Turn Windows Features on or Off. The
"Turn Windows Features on or off" window will appear. Scroll down the list
to find "Tablet PC Optional Components". Uncheck the checkbox and click OK.
This will remove all the Tablet components including the Tablet keyboard.
The normal OSK.EXE Onscree keyboard will be unaffected; likewise, your
graphics tablet should continue to work fine.

BTW you can look in Task Maanger to see if you have a process called
"osk.exe" running - that will show whether the keyboard is the "normal"
Windows Onscreen keyboard, or the Tablet keyboard. If osk - normal keyboard.
If no osk in Tasklist, but you see a keyboard on screen, it must be the
Tablet keyboard, as Synapse suggested.

If after all that, you still haven't found the cause of the keyboard
appearing, then .. I really dunno. In this case you may have overlooked one
of the above steps. Repeat the whole process again, slowly and carefully.

anthonyb21Author Commented:
i have tryed all of your answers but still no luck. i went over all settings again in easy access everything is unchecked. i even used msconfig by not running anything on startup. but it still shows up. the task manager does not show the osk.exe file running. i even used regedit and came up with nothing. i would think that if i turned off all startup programs that it would not show up.
anthonyb21Author Commented:
I would like to thank everybody who helped in this matter. Just to bring you up to date I had to do what HP calls a distructive recover ( fdisk and reinstall ) It is a Vista issue or so they say.
Thank you again on and all for all of your help.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now