IE 7.0 failed to surf any website

Dear EE members,
I have a WIN XP SP2 OS. Recently, I have installed IE 7.0 in my PC. But it failed to surf any website, i.e:
www.google.com. But, I am still able to surf www.google.com with my existing Mozilla browser.

When I uninstall IE7 from Add/Remove Program. The IE 6.0 is workable to surf net.

Do you know why?

Any suggestion to resolve this problem?

Regards,
Peter
peter_chongAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

war1Commented:
Hello peter_chong,

1. An addon may be interfering with IE. Disable Addons.  Go to Tools > Add-on Manager, and uncheck the addons.

If you cannot open IE, start IE without addons.  Go to Start > All Programs > Accessories > System Tools > Internet Explorer (No add-ons).

2. Reset IE settings.  Go to Tools > Internet Options > Advanced.  Click on "Reset" button. Click OK. Close all browsers. Reboot the computer.

3. Check if a program running in the background is interfering with Internet Explorer. Temporarily disable antivirus, firewall, antispyware, ad-blocker, popup blocker, and all Norton programs.


Hope this helps!
war1
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
skree358Commented:
Try going to the internet options window and uncheck "enable third party browser extension" in the advanced tab. You may also try resetting the defaults by clicking reset on the same tab. If all else fails, you can just go ahead and uninstall IE 7 and revert back to IE 6.
0
peter_chongAuthor Commented:
Hi war1,
FYI, I just start installing IE7 in my PC.

It initialise with this link after reboot the computer
http://go.microsoft.com/fwlink/?LinkId=74005

I can complete the customisation steps of IE7 via Mozilla instead.

But IE still cannot surf any web site, after I attempted all suggestions.

Sometime, it prompt out invalid address in the page or http:/// in the address bar.

Any other suggestion?

TQ.

Rgds,
Peter
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

war1Commented:
peter_chong,

If IE7 always goes to the RunOnce page on startup, even after you've tried to save the first run settings, it's possible that the mechanism that IE is using to save the settings does not work for some reason.

You can prevent IE from going to the RunOnce page and cause it to go directly to your homepage by running this script.
http://enhanceie.com/dl/NoRunOnce.reg
0
peter_chongAuthor Commented:
I have double click NoRunOnce.reg to add it into regedit.
A pc restart has been performed.

But IE 7 point to http://go.microsoft.com/fwlink/?LinkId=69157

I open http://go.microsoft.com/fwlink/?LinkId=69157 in Mozilla
It shown http://www.msn.com/

The IE 7.0 still statue quo in the same problem.

Any idea?

Many thanks.
0
war1Commented:
What happens when you try to go to www.google.com in IE7?

You may have a program interfering with IE.  If you turn off all external programs, will IE7 surf websites?
0
skree358Commented:
When opening your homepage, try to click on another tab, which opens tabbed browsing. Then try to go back to your homepage. If you were able to open your homepage successfully, then there might be a virus or spyware on your system.
0
peter_chongAuthor Commented:
no  external program opened.
open www.google.com
The screen attached show the output.

tabbed browsing show the same screen.

Alternative: Remove IE7 from Add/Remove Program. Restore to IE6.0 -> I.E 6.0 work.

I don't know why this happened.
errorPage.GIF
0
peter_chongAuthor Commented:
0
war1Commented:
Check your Connections tab in Internet Options menu of IE.  Make sure no proxy or auto detect is selected.
0
Marc ZCommented:
Peter, what firewall do you have installed on this machine?
What Security programs installed?

See http://forums.mozillazine.org/viewtopic.php?p=2295421#2295421 I know this references Firefox, but it addresses the issues of firewalls over all.
0
peter_chongAuthor Commented:
No proxy or auto detect is selected -> I use dial up modem.
Norton firewall -> IE is enabled.
0
Marc ZCommented:
Norton firewall. What Version?
Have you tried removing IE from it's list after closing IE and making it ask you again.
From this page and for version NIS 2007
http://service1.symantec.com/Support/nip.nsf/docid/2007020102112236?Open&src=hot&docid=2007051003541236&nsf=nip.nsf&view=docid&seg=hho&lg=en&ct=us
Turn off Personal Firewall
            
1    Start Norton Internet Security.
2    On the Internet Security Tab, click Settings.
3    Under Web Browsing, click Personal Firewall.
4    Click Turn Off.
5    Select Until System Restarts, and then click OK.

Try it now.
0
war1Commented:
peter_chong,

Uninstall IE7 and Windows will revert you back to IE6.  Test if you have surf the internet with IE6.
0
peter_chongAuthor Commented:
Dear EE members,
After revert back to IE6, It can surf the web.
The Norton firewall is not the issue.

Regards,
Peter

0
Marc ZCommented:
Peter,
When you installed IE7, were you connected via Dial-up or disconnected?  Try connecting with dial up, THEN open IE7.  Perhaps IE7 doesn't know how to start your dialup networking.

If this were mine and I were troubleshooting, I would be Connected, then install IE7, unfortunately it requires a reboot, which would cause the dialup to be disconnected, so once you get to the point of rebooting, do it manually instead of Automatically with IE7.  Reboot, start up your dial up connection again and then try to connect.
0
war1Commented:
Does IE7 always come up in runonce page?  if so, it's possible that the mechanism that IE is using to save the settings does not work for some reason.

You can prevent IE from going to the RunOnce page and cause it to go directly to your homepage by running this script.
http://enhanceie.com/dl/NoRunOnce.reg
0
peter_chongAuthor Commented:
Dear EE members,
I have managed to solve this problem. After I update Mozilla, web page cannot display error also happened in Mozilla beside Internet Explorer 7. After I clean all program listed in Norton firewall 's program control, all IE and Mozilla browsers failed to surf any web page from Internet. The add program
to list also failed in my case. Hence, I remove the Norton product as a temporary solution. Next, I reinstall
IE 7 and Mozilla software after restart the computer. It 's works. Next, I reinstall back my Norton product.

Cheers,
Peter
0
war1Commented:
Peter, glad the problem is fixed.  It was due to a program running in the background, Norton firewall, as I originally posted in the first comment.  Uninstalling it allow the browser to work.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.