?
Solved

Network Connections is empty.  ipconfig returns ONLY "windows IP configuration" then empty command line

Posted on 2008-02-07
6
Medium Priority
?
19,735 Views
1 Endorsement
Last Modified: 2009-07-29
Computer was working fine except that Symantec wouldn't update.  Removed Symantec Client Protection.  Computer still working.  Downloaded new version of Symantec.  Rebooted.  Computer still working.  Opened Symantec Antivirus 2008 (no firewall crap just plain Antivirus).  Lost connectivity.  I am performing all of this from 300 miles from the computer.  Person on the other end uninstalled Symanec and rebooted.  Still no connectivity.  Performed System Restore to this morning when system was working.  Computer only boots to a blank blue screen after log in.  I could connect but I also saw blank screen.  Reboot didn't help so reversed the System Restore and back to no connectivity.  Still reports that the Network Connections window is EMPTY.  No connections show up.  NICs appear properly installed in Device Manager.  IPCONFIG returns "Windows IP Configuration" and a blank command line.  

Tried a couple other restore points to no avail.  Tried solutions on this site such as resetting TCP/IP and Winsock.

Checked that Network Connections Service is started.

Help.
1
Comment
Question by:ddalrymple
5 Comments
 
LVL 11

Accepted Solution

by:
Zenith63 earned 1000 total points
ID: 20862982
This may be completely unrelated as it wasn't Symantec AntiVirus on the machine in question, but I came across a PC where there were no Network Connections listed.  The solution was to run the following three commands then reboot.

regsvr32 netshell.dll
regsvr32 netcfgx.dll
regsvr32 netman.dll
0
 

Author Comment

by:ddalrymple
ID: 20862992
Oh yes.  thanks for the reminder.  I found and tried that too.  other ideas?
0
 

Expert Comment

by:malibu4372
ID: 21025255
I'm in a very similar situation.  I was trying to replace a wireless driver in Windows, and now it seems that it's taken down all of my TCP/IP connectivity altogether.  Unlike the author above, i never had Symantec installed.  
I've run winsockfix, i've uninstalled/reinstalled the wireless drivers, i've uninstalled all of the network adapters in Device Manager (and then reinstalled them), i've added/removed the different clients and services in the LAN/WLAN connections, etc, etc.  One thing i notice is that, like above, i somehow can still magically "scan" the network for other local wireless networks.  However, when i'm supposedly connected to a network, this always shows that i've sent a ton of packets, but Windows doesn't seem to be recognizing Received packets (received packets = 0).  At the command prompt when i type ipconfig /all, nothing comes back (only the top line header, stating something like "Windows IP Configuration."  I'm really running out of things to do or try here, any suggestions?
0
 

Expert Comment

by:crcevans
ID: 21884263
Try booting into safe mode, removing the network card drivers, and reboot.

I just had the same situation after installing the latest symantec endpoint protection firewall/antivirus client.

Nothing worked until I gave it a chance to reload the network card drivers.
0
 

Assisted Solution

by:NoahK17
NoahK17 earned 1000 total points
ID: 23999597
I had the same issue with my Dell Mini 9, and the order to fix things was this:

- Reinstalled all wireless/wired drivers from Dell
- Reset my Winsock using netsh: http://support.microsoft.com/kb/892350
- Reinstalled Winsock/Winsock2 using these instructions from MS: http://support.microsoft.com/default.aspx?scid=kb;en-us;817571
- Ran the 3 DLL register commands from the first post.
- Ran Winsock XP Fix for good measure: http://www.snapfiles.com/get/winsockxpfix.html
- Rebooted Windows
- Pinged Google with success.

Good luck!
1

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
In this article I will be showing you how to subnet the easiest way possible for IPv4 (Internet Protocol version 4). This article does not cover IPv6. Keep in mind that subnetting requires lots of practice and time.
Internet Business Fax to Email Made Easy - With  eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, f…
There's a multitude of different network monitoring solutions out there, and you're probably wondering what makes NetCrunch so special. It's completely agentless, but does let you create an agent, if you desire. It offers powerful scalability …

601 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question