unable to connect to internet

I have a comcast cable modem (Motorola SBV5220).  I connect to the internet on 2 different laptops.  Suddenly, one laptop (Windows XP) cannot connect anymore - I get an error that it cannot connect to the IP address.  When I try to repair, I get the unable to renew the IP address.  I don't think the problem is with the modem, because when I connect the network cable to my other laptop, it connects just fine (and thank goodness it does, because I'm using it to type submit this question!)

My attempts to fix the problem:
I checked the modem cables -- all connected
I unplugged the modem and removed the battery for over 5 minutes.
I ran ipconfig/release
I rean ipconfig/renew - I get this message:  An error occurred while renewing interface Wireless netowrk Connection: unable to contact your DHCP server.  Request has timed out.

I also tried this:
In Control Panel, double-click Network Connections, right-click Local Area Connection, and then select Properties.  
On the General tab, click Install, select Protocol, and then click Add.  
In the Select Network Protocols window, click Have Disk.  
In the Copy manufacturer's files from text box, type c:\windows\inf, and then click OK.  
Select Internet Protocol (TCP/IP), and then click OK.

I'm not very technical, and I have no idea what to do next.  Thanks for your help!
kimberlys777Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Doc_McAlisterCommented:
Does the light come on in the laptop port when you plug in the network cable?  The network card may be physically broken and not acknowledging the wire.  See if you can plug it in anywhere besides your home.
0
kimberlys777Author Commented:
Thanks for replying --

On the laptop that is not working the light is solid orange on the left and flashing yellow on the right.  
On the laptop that is working solid green on the left, flashing yellow on the right.  

Would the network card be physically broken even if the laptop hasn't been moved except around on the my desk?
0
Doc_McAlisterCommented:
Solid orange isn't good.  It may be bad hardware or it might be the driver.

Did it ever work?
If yes, can you remember anything that happened before it stopped working?
0
Cloud Class® Course: Amazon Web Services - Basic

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

Doc_McAlisterCommented:
I'm guessing that when you run IPCONFIG /all you see that the driver is "media Disconnected"?
0
kimberlys777Author Commented:
it worked for the past 11 months, up until about 5 days ago -- I haven't installed any new software, so I'm not sure what could be the problem.  

I got the "media disconnected" a few times when I tried ipconfig/renew (when I wasn't getting the "unable to contact your DHCP server" error).

I just ran ipconfig/all and I got a bunch of stuff:

Windows IP Configuration
Host Name = PRECISION-M70
Primary DNS Suffix = this is blank
Node Type = Broadcast
IP Routing Enabled = No
WINS Proxy Enabled = No

Ethernet adapter Wireless Network Connection"
Connection-specific DNS Suffix = this is blank
Description = INtel(R) PRO/Wireless 2915ABG Network Connection
Physical Address = 00-....
DHCP Enabled = Yes
Autoconfiguration Enabled=Yes
Autoconfiguration IP Address = 169.....
Subnet Mask = 255...
IP Address == fe80::20e....
Default Gateway = this is blank
DNS Servers = fec0::0....1%1
                          "" ""        2%1
                          "" ""        3%1

Ethernet Adapter Local Area Connection
Media State = Media disconnected
Description = Broadcon NetXtreme 57xx Gigabit Contorller

Then there's a bunch of stuff about a Tunnel Adapter Tunneling Pseudo-Interface and Automatic Tunneling Pseudo Interface
Then
NetBIOS over Tcpip = Disabled

(I don't know what all this means, but I suspect it's not good...)
0
Doc_McAlisterCommented:
If it was working then the driver you had is good.  So its not a driver issue.

Physical damage is still not off the table.  A power surge, for example,

But the fact that your *wireless* card is connecting to something is indicative.  If you go into Connect To -> Show All connections do you see both?

If so, right click and disable the wireless one and then try to renew the wired one.  It may just be getting shouted down, as it were, by the wireless.  You can re-enable the wireless one when you need it.


Good luck and good night =).  
0
kimberlys777Author Commented:
I disabled the wireless one and tried to renew the wired one (got the "an error occurred while renewing interface Local Area Connection.  Unable to contact your DHCP server.  Request has timed out.")

My connections are listed as follows:
Dial-up Connection: Disconnected, Firewalled
Wireless Network Connecion:  Disabled, Firewalled
Local Area Connection:  Limited or no connectivity, Firewalled

This is sooooo frustrating!  Good night, I'll check back in the morning to see if you have any other suggestions.  Thanks again for the help.
0
ExcelGuideConsultantCommented:
you can try to delete the network adapter and restart your windows. Windows will again install your network adapter. You might try to download newest drivers...

If it DID work like 2 days ago, then you might try System Restore....worked for me a couple of times...

Good luck
0
ridCommented:
Is the modem also a router? Can you connect more than one system at a time to it?
/RID
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kimberlys777Author Commented:
I don't know how to delete the network adapter, and the system restore doesn't work (someone told me it was because of the symantec antivirus program not allowing it).

I don't believe the modem is also a router - there is only one network cable connection port, so I don't think I can connect to more than one device at a time.
0
Doc_McAlisterCommented:
OK.

We know the wire and modem are good because they work for your other laptop.

We know that the modem is not hard coded to only talk to the other laptop because you were switching them around before.

We know that This modem *was* good, but stopped working.

We know that this modem is still set to DHCP so it should be able to request an IP address if the driver is good and the card is functional.

Either the card is bad, or the driver is bad, or both.

To remove the driver go to control panel, system, hardware, device manager, and find your card.  Right click on it to get to the removal option.  On reboot your computer should detect the card and try to install it (or use a driver disk that came with it if you have one).  

If it can not be reinstalled it is probably fried.
0
kimberlys777Author Commented:
Sorry for the delay in responding, I had no connection for a bit.  

I was able to connect using a friend's wireless network, so it was determined that while using a wired connection, my cable connection would only accept one computer id.  I hooked up a wireless router and now everything works fine.  (whew!)

Thanks everyone for the suggestions.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Broadband

From novice to tech pro — start learning today.