NET USE how to connect to a terminal server to see the open session

I need the command line to connect to a terminal server through console

I'm trying to use a command line like this:

net use /user:Administrator \\ipaddress\share


but I get an error "Network path not found" or something like this...
The ip address is correct :)
Any suggestion will be very appreciated

Giacomo
giviglieAsked:
Who is Participating?
 
Matthew MillersConnect With a Mentor Commented:
net use * \\server\share /user:domain\username

* will map to the next available drive
0
 
oBdACommented:
The syntax is
net use <Drive Letter> \\<server>\<share> <password> /user:<Domain>\User
So try the following:
net use * \\Ipaddress\share * /user:Administrator
The first asterisk will take the next available letter; you can replace that with the letter you want to map:
net use X: \\Ipaddress\share * /user:Administrator
The second asterisk will tell "net use" to ask for the password; you can enter it in clear text as well, but that's usually not so wise.
If the user you want to connect with is a domain user, you need to specify the NetBIOS domain name in front: DOMAIN\user. If it's a *local* account on the server, you can use only the name.
0
 
giviglieAuthor Commented:
ok but how can I check if the user is a domain user??? Maybe the question is simple but I'm not a server admin....

0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
Matthew MillersCommented:
Does the user exist in AD or is it created on the local machine (compmgmt.msc)?
0
 
giviglieAuthor Commented:
i've created the user with computer managment
0
 
Matthew MillersCommented:
It will probably be local then.

net use * \\server\share /user:username
You will then be prompted for a password

Or you can enter the password before /user
net use * \\server\share Password01 /user:username
0
 
giviglieAuthor Commented:
Ok
I've tried
net use * \\server\share * /user:username

and I've the same error

if i declare

net use C: \\server\share * /user:username

I obtain another error
The local device name is already in use

So I can reach the server....but something is missing

0
 
Matthew MillersCommented:
Try
net use * \\server\share /user:username
0
 
giviglieAuthor Commented:
Always error 53
and another thing I can't do the ping on the ip address
I've no answer....
But I can connect in remote desktop...

Hope it helps
0
 
johnb6767Commented:
net use C: \\server\share * /user:username

I obtain another error
The local device name is already in use

Change the C to a Z.... C is the local drive, hence the error message...
0
 
Matthew MillersCommented:
Are there any firewalls between or locally on the hosts?

can you type the following command:

net view \\servername
0
 
giviglieAuthor Commented:
I've already tried with net view but I obtain the same error 53.

i've made a ipconfig /all in the terminal server

IP ROUTING ENABLED :NO
WINS PROXY ENABLED :NO
NOTE TYPE : UNKNOWN

DHCP ENABLED :NO

HOPE IT HELPS
0
 
Matthew MillersCommented:
I mean on your workstation and the server, is the windows firewall enabled (control panel)

Is the server service running on the server
Is the workstation service running on your machine (client)
0
 
giviglieAuthor Commented:
Yes in my workstation no firewall
In the server firewall on with this exception:
Allowed
Remote desktop
http proxy
0
 
Matthew MillersCommented:
Is there any reason why you have a firewall running on the server?
Can you disable the firewall for a moment and see if the command works?
0
 
oBdACommented:
It seems like you're trying this over the internet to some dedicated host or whatever.
This will *not* work, and for a good reason. You do *not* want to expose SMB to the whole wide world.
Open a command prompt, enter
telnet ServerIP 445
If you get an error message, you won't be able to map a drive to this machine (unless you open the firewall, which, again, is *nothing* you should consider in earnest).
If you need to swap files, you can try to enable mapping the local drives into the RDP session (click the Options button when starting mstsc, then look under the "Local Resources" tab).
0
 
giviglieAuthor Commented:
firewall disabled....
i can't restart the terminal server

the command doesn't work...
0
 
oBdACommented:
Again: if you are trying this over the internet, RE-ENABLE THE FIREWALL NOW!
Last I remember, the average time before an exposed machine gets attacked is less than 1 minute. Next Tuesday, Microsoft will release 12 patches, several of which considered high risk. Even if the server should have the current patches, you can not exclude that some of those weak points will be used to try to take control over your machine.
It would make helping you a *lot* easier if you were telling what *exactly* you are trying to do.
0
 
giviglieAuthor Commented:
ok...
Sometimes when i connect to terminal server with remote desktop i get the error:
"Terminal Server Has Exceeded the Maximum Number of Allowed Connections"
I would like view the open sessions and close some session....

Thanxs

Giacomo

0
 
Matthew MillersCommented:
Completely agree with oBdA, did not crack onto the fact that you are doing this over the internet.
0
All Courses

From novice to tech pro — start learning today.