Exchange 2007 Content Conversion/Encoding issue

Experts

Here is possibly the trickiest question I will ever ask and if anyone manages to remotely get near to the answer I will send you a crate of beer!

Exchange 2007 Content Conversion/Encoding issue

I have a client who runs Exchange 2007 and its been running for some time quite happily.  But in recent months they have started getting jumbled messages that are being encoded incorrectly when an attachment is sent to users in the organisation from an external domain (one of their customers).

Now I have spent many hours researching this and I am going to put a call into MS though I am not sure if they can assist but what happens is the mail comes in like this:

**************************************************************************************
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-MimeOLE: Produced By Microsoft Exchange V6.5
Content-class: urn:content-classes:message
MIME-Version: 1.0
Content-Type: multipart/mixed;
        boundary="----_=_NextPart_001_01C85E83.DCAA59DC"
Subject: Gerry Sutcliffe
Date: Thu, 24 Jan 2008 12:24:51 -0000
Message-ID: <BC10858B57DF47478DD0BBF71F7150030120EF4E@server50340.exchange.london.genesis.local>
X-MS-Has-Attach: yes
X-MS-TNEF-Correlator:
Thread-Topic: User Name
Thread-Index: AchehB4jv1JAZ+I9R/qHy/OMYjFKaw==
X-Priority: 1
Priority: Urgent
Importance: high

The Email addresses of the people who this mail is sent to is put here but I have removed them for obvious reasons

------_=_NextPart_001_01C85E83.DCAA59DC
Content-Type: multipart/alternative;
        boundary="----_=_NextPart_002_01C85E83.DCAA59DC"


------_=_NextPart_002_01C85E83.DCAA59DC
Content-Type: text/plain;
        charset="US-ASCII"
Content-Transfer-Encoding: quoted-printable

The body goes here

**************************************************************************************

Now you might be thinking what the hell is all this?  I can explain with the assistance of some articles off of EE so bear with me as I try to tell you what I know so far! (Remember beer is up for grabs here)

http://support.microsoft.com/kb/323226/en-us - This article discusses how a message is made up in MIME format and the important part is this section:
Messages that are composed by MIME clients as a multipart/mixed MIME message without a "name" parameter for the "content-type" or an optional "filename" parameter for the "content-disposition" header may not be rendered correctly when received by Exchange.

Now according to this article - http://www.eggheadcafe.com/software/aspnet/30005443/-exchange-2007-content.aspx - a lot of people are suggesting that without all the correct parts to a MULTIPART/MIXED message then it gets scrambled.  Now one person says if he puts the code you can see above in a 64 Decoder it asks him to download the attachment (In my case its a word doc but his its a PDF).

The problem is I don't know how on earth I meant to fix this and what do I need to set on my Exchange 2007 box in order to stop it from moaning about not having the correct header information when attachments come in.

Anyone who can get this gets the beer cos I am perplexed!

Thanks
Rowan_InsiteAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

FC01Commented:
What firewall are they using?
0
Rowan_InsiteAuthor Commented:
Im just trying to find out that for you now - its something I haven't been able to get as the external source isn't as forthcoming with informaton as I am.
0
FC01Commented:
Have seen this problem caused by the SMTP proxy on Watchguard firewalls.  They do not as a defauly allow binary MIME.  If they are not using a Watchguard maybe you should check for something similar on their firewall.
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Rowan_InsiteAuthor Commented:
Ok I have checked my side and we have ticked the enable BINARY MIME option.  They have a Watchguard their end and I have asked the techincal people their end to check the box for me under the ESMTP settings.

Anything else you can suggest ?
0
FC01Commented:
What I did to overcome this problem for the people who had problems sending us attachments, there are only two of them, was to create a new rule on the firewall using the smtp packet filter rather than the smtp proxy.  So, create a packed filter to allow mail from ip address of sender to internal mail server.  As this is a more restrictive policy than the smtp proxy - which allows all smtp to internal mail server it will have a higher precedence in the list and will be triggered before the smtp proxy rule.
0
Rowan_InsiteAuthor Commented:
We have found a solution where we can actually set the default coding type in Exchange 2007.  Since we have done this we have yet to see the issue occur.



Thanks for your help!
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Rowan_InsiteAuthor Commented:
Please ignore my last answer because it is infact wrong - I have tried the encoding types available in this article http://support.microsoft.com/kb/946641/en-us 

Everyone so far has failed to fix the issue.  Still looking for the answer!
0
FC01Commented:
I am convinced that this is caused by your firewall as per my previous post.  Have you tried my suggestion regarding the smtp packet filter?
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Applications

From novice to tech pro — start learning today.