Microsoft, Exchange, 2007, System Attendant not starting

I am migrating our users from an Exchange 2003 Sever to a new Exchange 2007 Server.

After tranferring some of the mailboxes, the Microsoft Exchange System Atendant no the Exchange 2007 server sdtopped is now not starting (Automatically or Manually)

I am, getting these 2 errors in the event  viewer:
1.
Event Type:      Error
Event Source:      MSExchangeSA
Event Category:      General
Event ID:      1005
Date:            08/02/2008
Time:            01:30:25 PM
User:            N/A
Description:
Unexpected error An unknown error has occurred. ID no: ffffffec Microsoft Exchange System Attendant  occurred.

and

2.
Event Type:      Error
Event Source:      MSExchangeSA
Event Category:      General
Event ID:      2060
Date:            08/02/2008
Time:            01:30:25 PM
User:            N/A
Description:
The DSProxy failed to start, error '%1'.

What can I do to fix this error?
ywainaquaAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

zuechCommented:
I had a similar situation with a client's 2003 Exchange Server where I couldn't figure it out so I had to call Microsoft and it turned out to be my Symantec Anti Virus. There were no logs in the event viewer though. The service wouldn't start up after working for years. Here are the articles they sent me when that happened. I didn't find anything about that in 2007 but I don't have any clients on 2007 yet and we use Lotus until I'm done beta testing 2007.

http://support.microsoft.com/kb/823166

http://support.microsoft.com/kb/822158

http://support.microsoft.com/kb/245822
0
ywainaquaAuthor Commented:
Hi,
Thanks for the insight and the links. I removed the Symantec AV from both the Exchange 2003 and 2007 Servers, but still no luck on the System Attendant starting on t he Exchange 2007 server.
0
zuechCommented:
Here are a few other links associated with that error.

http://support.microsoft.com/kb/251640

http://support.microsoft.com/kb/251640

The first one is associated with 2000 but ultimately has to due with restarting the global catalog server. I can't imagine this is the scenario but the second one could be possible, the NWLink protocol is enabled on your network interface card.

I've seen a few articles now on this and it almost everytime has to do with connectivity to the DC. Also look at the date listed in the event viewer logs. It looks like you are way off from the correct date which if it isn't syncing with your time server (typically DC) can cause all types of issues. start there and let me know.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

ywainaquaAuthor Commented:
Hi Zuech,
Thanks for your reply, I tried to do the registry changes and still no luck. Upon making the changes none of the MSE Services started.

Although I did get new errors (Pasted below):

Event Type:      Warning
Event Source:      MSExchange Autodiscover
Event Category:      Core
Event ID:      1106
Date:            14/02/2008
Time:            01:34:46 PM
User:            N/A
Computer:      ANGLER
Description:
Error "Microsoft.Exchange.Autodiscover.Providers.Outlook.OutlookAutoDiscoverProvider" while loading the assembly "System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> Microsoft.Exchange.Data.Directory.ADTransientException: Microsoft Exchange Active Directory Topology Service cannot be contacted via RPC interface, error 0x6D9. ---> Microsoft.Exchange.Rpc.RpcException: Error 6d9 from HrGetServersForRole
   at Microsoft.Exchange.Rpc.ADTopology.ADTopoRpcClient.HrGetServersForRole(String[] currentlyUsedServers, ServerRole role, Int32 serversRequested, ServerInfo[]& suitableServers, Int32[]& mapping)
   at Microsoft.Exchange.Data.Directory.DSAccessTopologyProvider.GetServersForRole(String[] currentlyUsedServers, ADServerRole role, Int32 serversRequested, Int32[]& mapping)
   --- End of inner exception stack trace ---
   at Microsoft.Exchange.Data.Directory.DSAccessTopologyProvider.GetServersForRole(String[] currentlyUsedServers, ADServerRole role, Int32 serversRequested, Int32[]& mapping)
   at Microsoft.Exchange.Data.Directory.DSAccessTopologyProvider.GetConfigDCInfo(Boolean throwOnFailure)
   at Microsoft.Exchange.Data.Directory.TopologyProvider.PopulateConfigNamingContexts()
   at Microsoft.Exchange.Data.Directory.TopologyProvider.GetConfigurationNamingContext()
   at Microsoft.Exchange.Data.Directory.ADSession.GetConnection(String preferredServer, Boolean isWriteOperation, Boolean isNotifyOperation, ADObjectId& rootId, Int32& maxRetries)
   at Microsoft.Exchange.Data.Directory.ADSession.GetReadConnection(String preferredServer, ADObjectId& rootId, Int32& maxRetries)
   at Microsoft.Exchange.Data.Directory.ADSession.Find(ADObjectId rootId, String optionalBaseDN, ADObjectId readId, QueryScope scope, QueryFilter filter, SortBy sortBy, Int32 maxResults, IEnumerable`1 properties, CreateObjectDelegate objectCreator, CreateObjectsDelegate arrayCreator)
   at Microsoft.Exchange.Data.Directory.ADSession.Find(ADObjectId rootId, QueryScope scope, QueryFilter filter, SortBy sortBy, Int32 maxResults, IEnumerable`1 properties, CreateObjectDelegate objectCtor, CreateObjectsDelegate arrayCtor)
   at Microsoft.Exchange.Data.Directory.ADSession.Find[TResult](ADObjectId rootId, QueryScope scope, QueryFilter filter, SortBy sortBy, Int32 maxResults, IEnumerable`1 properties)
   at Microsoft.Exchange.Data.Directory.Recipient.ADRecipientSession.FindBySid(SecurityIdentifier sId)
   at Microsoft.Exchange.Autodiscover.Providers.Provider.GetQueryBaseDN()
   at Microsoft.Exchange.Autodiscover.Providers.Outlook.OutlookAutoDiscoverProvider..ctor(RequestData requestData)
   --- End of inner exception stack trace ---
   at System.RuntimeMethodHandle._InvokeConstructor(Object[] args, SignatureStruct& signature, IntPtr declaringType)
   at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   at Microsoft.Exchange.Autodiscover.ProvidersTable.LoadProvider(RequestData requestData, Object[] constructorArgs)".
Stack Trace:%3. This error may occur because the provider file is corrupt, is in an incorrect format, or has insufficient permissions.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
0
ywainaquaAuthor Commented:
Some more insight to our setup:

Server1 - Exchange 2003
              - Windows 2003 Server Enterprise Edition
Server2 - Exchange 2007 (Mailbox, Hub Transport, Client Access)
              - Windows 2003 R2 Server x64 Enterprise Edition
Server3 - Exchange 2007 (Client Access, Hub Transport) - Used for Frontend Web Access:OWA
              - Windows 2003 R2 Server x64 Enterprise Edition
Server4 - MS AD Server (Windows 2003 R2 Server x64 Enterprise Edition)
0
Zorflieg1Commented:
I had this error.  It can be caused by different protocols being installed on the server.  I setup a 2003 x64 R2 standard server and installed exchange standard 2007 sp0 and it said the error you mentioned immediately during the install.

The first time i set it up as a domain controller with a variety of components i wanted.  The second time was a very bare install with very little installed.  The same error happened.

I scoured the net for solutions and found a post from an admin saying when he installed tcp/ip ipv6 it started working.  Also there is a microsoft knowledge base article saying having IPX NWLINK can cause this.

I then realised that one of the things in common with both installs was i ticked Appletalk Protocol on both installs.

So my solution was i removed Appletalk and just for the heck of it installed IPv6, rebooted and it worked perfectly.

Then i immediately applied Ex 2007 sp1.  So far so good.
0
zdenizCommented:
I had this error too.
in my case it happens, when databases has been mounted before Sistem attendant service start.
my way was simple:
1. dismount all databases
2. start microsoft Sistem attendant service.
3. mount databases
All works fine
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.